I can not load my Telus Rewards page


This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.


I can log into my telus.com profile just fine but when I click on "Go to your telus rewards account" It just keeps loading and then flashing to a white screen then loading again. Nothing ever comes up. I have tried multiple browsers and devices. Cleared cache and cookies. Still no luck. I know other people can get into their accounts. Not sure what to do

Community Power User
Community Power User
Like your friends, I, too have no problem accessing the rewards page. If you have an eligible account (not every Telus customer is yet eligible), I suggest contacting Telus through Facebook or Twitter support pages to ask about resolution of the page.
If you find a post useful, please give the author a "Like"
Friendly Neighbour

Having the same issue with the rewards page attempting to load over and over again.


4 hours ago, I used most of my pints balance to purchase a gift card. No confirmation of that transaction via email and now the rewards page will not load for me. This is disconcerting as my point status appears to be limbo.


Any suggestions, Telus?

Community Power User
Community Power User

Try contacting Telus directly, especially if you tried spending points on something and ran into a problem.

Also from the FAQ:

How long does it take to receive my reward?

It depends on the reward. Most rewards do not need to be shipped, therefore it should take between 24-72 hours for your reward to be sent to your email or added to your account. An estimate is provided with each individual reward description.


What happens if I didn't receive my reward?

Double check that you properly redeemed your reward by checking your TELUS Rewards account which can be accessed in My TELUS. If you still have problems, please contact a TELUS representative.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Same is happening to me. I sat on the phone with 2 different telus reps and couldnt fix it


Same has been happening for my son for months, can't access his points, he sits on the phone for hours only to be told no one knows what's wrong, still, but they'll call him with an answer. Naturally no one ever calls. He gave up the other day and left Telus completely for Shaw and Rogers. He's been half gone for a while, half Telus, half Rogers. The combination of bad services from Telus was just too much for him. Rogers customer service has treated him so much better, without tech issues.