Showing results for 
Show  only  | Search instead for 
Did you mean: 

CE Smart Plugs

Just Moved In
It’s February 2024 and I’m new to Telus as of December. I just wanted to check with forum members to see if anyone has resolved the CE Smart switches being unable to pair with Telus equipment? I’ve tried everything I could think of temporarily turning off the 5Ghz network, locking 2.4Ghz network to channel 11. Factory resetting all Telus equipment. Factory reset all CE Smart switches. Removed the app from my phone and made a new account with CE Smart.
Talked and handed over my computer to tech support four times, let them have a go at it.
Nothing worked, forum members you are my last hope. Any one hear of a solution or an idea?
Thanks in advance, Go Oilers !!

Community Power User
Community Power User

I have no issues getting a  more well known brand of smart devices to work with Telus hardware. Specifically the TP-Link Kasa and Tapo products which also use 2.4GHz. Which router do you have from Telus? Do you also have Telus Boost?


CE Smart is another one of those companies that likes to hide information on who they are and where they're based. They have no contact info on their site at all besides a generic form. Considering their main URL referenced in their privacy policy doesn't even lead to a functional website, I'd be cautious buying their products.



If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Found a solution that worked. I put the switches in AP mode ( Access Point Mode ) and finally got them to connect. I’m guessing this will work for other manufacturers that you are finding hard to connect.