cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus TV+ on Chromecast with Google TV not playing video

RS2
Just Moved In
Hi,
I just got Optik TV and installed the Telus TV+ App on my Chromecast with Google TV and it won't play anything. I have tried Live TV, On Demand, and from the Guide and it always loads for 1 minute and then gives me error code ERR_PLAYER_P001. Other video apps work and do not have any issues. Any idea on how you fix this?
Thank you for any help.
3 REPLIES 3

WestCoasterBC
Community Power User
Community Power User

Verify your chrome cast with google tv software is up to date. Uninstall then reinstall the app. Then reboot the device. Sign back in and see if it now works.

Hi, thanks! I have tried that and nothing has worked. I did find out after posting this that 3 very random channels do work and load quickly, but the rest cause the error.
I felt I should also add that it works well on my computer.

El-Eric
Moderator
Moderator

Hey @RS2 I would double check that you're using your Chromecast with Google TV and not the Google Chromecast or Google Ultra as neither of those devices are supported.