Showing results for 
Show  only  | Search instead for 
Did you mean: 



After the recent update to the above on an Apple Ipad, I can no longer view my Recorded or Scheduled recordings on the Ipad.

The same issue shows up when I go to record a program. I reveive the message “Could not add recording”.

However, when I go to the guide on my tv, it shows that the recording was added and when I then go to the pvr, my recordings and scheduled recordings show.

I have logged out; logged in; deleted the telustv+ app and reinstalled it; unplugged the modem; unpluged the pvr boxes and replugged everything.

Nothing works as my App still shows I can’t record a show nor can I see the Recorded or Scheduled Recordings.

Everything worked well until the recent update to Telus+ occurred which was  “supposed” to be an upgrade but now  really appears as a downgrade.

What is my next step to get back Ipad ability to make these issues go away and get back to normal?


Community Power User
Community Power User

I just checked my iPad and I am able to view scheduled and recorded shows. It's possible Telus was making changes to the service while you were tryiing to access that information.


From your description it would seem you have tried everything that you can do from your end.


With the launch of the new Optik TV+ I'm sure there is a lot going on behind the scenes to make this all work and there will certainly be some hiccups until it's all sorted out.


Just a long time customer hoping to help.