Showing results for 
Show  only  | Search instead for 
Did you mean: 

iPhone not displaying a badge when I have voice mail waiting to be heard


When I have unheard voicemail messages, my iPhone is not displaying a 'message waiting' badge (red dot) above the "voicemail" icon at the bottom right of the list of incoming and outgoing calls. 


The phone does display a notification above the "Recents" icon after the call comes in: but it never displays a notification above the voicemail icon.


This is on an iPhone 13 running iOS 16.1.  


I've checked and the Notification settings seem correct (Alerts settings are -- Banner-style: persistent; Badges:  "ON"). I tried powering down and restarting the phone, but that does not resolve the problem.


Does anyone know how to fix this?  It is more than annoying to not know you have waiting voice mail.....




Community Manager
Community Manager

You'll likely need to re-program your voicemail box number but to do that, you'll need to contact tech support to get your server number. Once you have that in hand, you can program it as follows:

- Tap the Phone app

- Enter *5005*86*"voicemail server number"#

- Tap on Call to program the number

The problem is not solved but I'm part way there. I called tech support and the found my vmail server was really messed up so they reset it completely: had to set a new password and greeting (and lost the vmail that was there).  So I then called my phone twice (from a separate line) and left a single voice mail message. The phone popped up banners when the calls came in and afterwards I saw a badge on the phone app icon:

phone app icon.PNG

When I open the phone app I then find a badge on the Recents icon - but no badge above "Voicemail", even though I left a message.  I verified the latter by tapping on this icon and hearing the "you have one unheard message' prompt from the voicemail server.  

phone app screen.PNG


Any other ideas? I checked Settings -> General -> About for software updates, but there are none pending..

Community Power User
Community Power User

Have you rebooted your phone?

Community Manager
Community Manager
Did you ask for the voicemail server number and use it to program your phone, by chance?

To WestCoasterBC: Yes I rebooted the phone - that did not help.

To Dru: I forgot to ask for the server number:  I asked the tech guy what he was doing and he said he was going to reset the server, which I thought was the same thing... I will call back again to day and get the server number and do the phone reprogramming, as you suggested.

Hi Dru  - I called back to tech support and talked to a new person. He poked about and said  the voice mail server was again messed up and needed to be reset (ominously the same as what the guy said yesterday). He then tried a bunch of things,  including asking me to do a phone network reset    (Settings -> Reset -> network reset ... mini reboot of phone)  ..  Did not fix it.  He then said he had to talk to "tier 2" tech support and would call back in an hour ......  and that's the last  I heard from him (it's been 3 hours now...). I think I've been ghosted by tech support 😉  Will wait and maybe try again tomorrow ...... Kinda wish Telus tech support had tickets so you could have continuity from person to person .....