Showing results for 
Show  only  | Search instead for 
Did you mean: 

TELUS Rewards page not loading


When I try to access the rewards page from a browser this is all I get:



It works when accessing from the My TELUS app and I'm able to select a reward to redeem but then I get this:

I've waited and tried later several times now with no luck.

164 REPLIES 164

Friendly Neighbour

I was able to solve this by using the following workaround: Launch Google Chrome in incognito mode and login from there. It worked no problem.

I've had the same issue for weeks, no rewards page, and again today. (Sat March 30th)

BUT going into incognito mode, as you suggested........immediately I could access my rewards !

Thanks for the workaround !!!!!!!!!!!!!!!!!!! 😀😀


Friendly Neighbour

You're welcome! Glad it worked out.

I don't think you work for telus, but since you came up with a simple workaround while the telus gurus, take months to fix the problem, you could become a "Community Manager".

Just saying !


Friendly Neighbour

Ha, ha. Yeah, I should be on their payroll! Fortunately for me, I'm retired so I don't have to work any longer but glad to help out where I can.

Going into incognito mode still doesn't work for me. Are there any workarounds that works now that didn't work a few weeks ago?


still not working,  can not redeem as at Feb 8, 2024

Friendly Neighbour
common Telus get the IT tech department on it


I've been having the same issue for weeks now too, and I've followed every trouble shooting suggestion given by tech support. I also didn't get the extra 5 points for signing up for the automatic monthly payments they offered. It's definitely become discouraging and quite frustrating having to wait for weeks, plus feeling customers are receiving little to no support from customer service! 


The reward page was working for me for a while but it's now back to not working.


I cleared all data for the site in Chrome and now I can't log back in because the site is asking for the 2FA code and the code is not showing in the My TELUS app. I've tried on multiple devices with the same result.


I'm stuck now not being able to log in at all to My TELUS from a browser. I can still log in to the app fortunately, it's just not showing me the 2FA code.

TELUS Team Member
TELUS Team Member

Hi @xray,
In regards to your 2FA code not generating, there are two ways to generate the code.
A) Have the app open, and wait for the pop-up containing the code.
B) Open the app, click the 3 lines on the top left of the app, tap Contact and security settings, then click Get a verification code. 


Hope that helps! 🙂

I have been trying with method A. The app never gives the pop-up.

I also tried method B but there is no menu item to Get a verification code:


I've also tried a phone reboot and force stop on the app. The only thing I haven't tried is a reinstall but I'm hesitant to do that as it's my only way to access my account right now since I'm locked out of all browser access.


also not able to access from chrome or other websites after clearing caches. 

TELUS Team Member
TELUS Team Member

I was able to successfully redeem my rewards today 02/10/2024, here is how.


Before you think or say "I already cleared my cache and cookies" hear me out.
There are multiple ways to clear cache and cookies, you might be missing one of the steps.


The following instructions will be for a computer using Google Chrome.
1. Go to
2. Click the lock icon to the left of the URL, and click the Cookies and site data option.


3. Then click Manage cookies and site data


4. Click every trashcan icon until there are no more. Then click Done.


5. Click Reload


6. Click Access your rewards


7. Once you are logged in, you will be at a new website URL:

8. Repeat the entire process again starting from step 2 to clear the cache and cookies from this page.

9. Login, and the issue should be fixed. 

Note: You may do this during a time where there is heavy traffic, and or website maintenance making the solution above appear that its not working. If you are still having difficulties retry these steps in a few hours or the next day. If the issue still persists, this resolution may not be for you and I encourage you to continue to post, and include screenshots (but make sure to blur out any personal information including the ending of the URL

That's exactly what I did and got up to step 6 where I encountered the 2FA problem because my 2FA token was cleared and I needed a new one.

TELUS Team Member
TELUS Team Member
Yes, with the steps I shared, it will require you to login 2x. If you have 2fa enabled, it will also require entering the 2fa x2 also (they don't have to be the same code). Please try following those steps again and when you get to step 9, login using a newly generated 2fa code. Does this work for you? If not, what step did you get stuck at, and what does the page look like?

It doesn't work for me because the app is not giving me a code.
See my previous post:

Friendly Neighbour
Oops something went wrong...
If you think this is an error, please wait 24 hrs and try again.
It says this!!!! no one can get into the catalog. computer issues with Telus. It is very irritating

I have done this multiple times and still cannot access the page 

Friendly Neighbour

This does not work at all. Thanks for nothing.

TELUS Team Member
TELUS Team Member

@xray We both seem to have different URL's when trying to access or dashboard.
I'm curious what happens if you delete the eban/[**********] portion, and click enter. 

You have:[*****************]
I have: