iPhone: Roaming Texts

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

KittyGumDropz
Ambassador

Incoming texts cannot be declined unlike how we do on calls. There's another way to avoid roaming charges while using the iMessage. Just go to Settings > Messages > Turn off Send as SMS.

 

**Note: Data roaming charges may apply because using iMessage(Apple to Apple only) requires data. Turn off the data(Settings > Cellular > Turn off Cellular Data) to avoid the charges and connect your phone to wifi(Settings > Wifi > On/Off). Wifi is a free service for the phone but if you don't have any wifi in the area, better call Customer Service to add data roaming pass by dialing *611 and it's free of charge even if you're out of the country.

xXKittyGumDropzXx