cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Extremely slow LTE Advanced speeds in Uxbridge

consume_tofu
Just Moved In

Hi, Just signed up for Telus and got my iPhone 13 Pro in the mail yesterday. Tried performing several speed tests over the past 24 hours with the speedtest.net app and I'm finding it impossible to break 7 Mbps down and 2Mbps up.

 

My phone reads 2/4 bars of LTE signal when performing the tests and the tower I'm assuming I'm connected to which is owned by Bell and used by Telus is about 1KM away from my location. The coverage map on the Telus site shows my house as being blanketed in LTE Advanced coverage.

 

Is there something wrong with my line, or is that tower just completely oversubscribed by all of the fixed-home wireless internet connections Bell is offering in town to residents while they build out fibre-to-the-home? I tried performing a test very early in the morning so you would think that I would have avoided peak-hour network congestion.

 

For reference with my Fido SIM I easily get over 100 Mbps in the middle of the day.

1 REPLY 1

NFtoBC
Community Power User
Community Power User

Have you tried sufficiently distant from your home location to connect to another tower?

 

NFtoBC
If you find a post useful, please give the author a "Like"