Connection to outgoing server smtp.telus.net failed

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Resident

I am travelling in Mexico and get the above message when trying to send mail from my telus.net account. Mail doesn't get sent. Using my iCloud.com address works fine. What can I do?  I tried using the iCloud outgoing server as a secondary server to back up the Telus one, but it couldn't be verified and didn't work. Is there something I'm entering incorrectly. I entered smtp.iCloud.com


Accepted Solutions
Highlighted
Most Helpful
Community Power User
Community Power User

Can you send through the web portal? https://webmail.telus.net/  I have had this message come up in the past, and had to do with the wifi connection i was connected to.


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

View solution in original post


All Replies
Highlighted
Most Helpful
Community Power User
Community Power User

Can you send through the web portal? https://webmail.telus.net/  I have had this message come up in the past, and had to do with the wifi connection i was connected to.


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

View solution in original post

Highlighted
Resident

Yes that seems to do it. Thank you very much for the tip.

Highlighted
TELUS Employee
TELUS Employee

Whew! @WestCoasterBC saves the day! That one was beyond me!

Mobility Client Care Rep
Highlighted
Friendly Neighbour

Port 1025 for your SMTP server _might_ work.  But a better idea for foreign access from the mail client of your choice is to use a third party service like SMTP2Go.  Took me a while to find it when 1025 crapped out and after WASTING hours with tech support, they finally suggested that I pay $60 for "advanced support".  yeah, right.  Telus needs to fix its SMTP servers.