Showing results for 
Show  only  | Search instead for 
Did you mean: 

Samsung Note 8.0 touch screen stops responding to input

Just Moved In

My tablet (sgh-i467m) takes fits where the screen stops responding to touch input for 3 or 4 seconds at a time.  Whatever is on the screen keeps going on as normal,  but tapping the screen does nothing.  It happens every minute or so,  and sometimes as often as 3-4 times a minute.  I've researched this,  and pretty much every note 8.0 running 4.1.2 does it.  Other market versions of this tablet have been updated to 4.2 and even to 4.4 kitkat . 

I've even done a factory reset and it's still the same,  and it's really frustrating.  If telus or Samsung doesn't fix this I'm returning my tablet. 


Community Power User
Community Power User

If you've had it for more than 14 or 30 days, Telus can't help. It sounds like an issue with the tablet itself making it a Samsung problem. If it's over a year old it is likely that the warranty has expired as most tablets only have a one year warranty and 4.1.2 appears to be the newest OS for that specific model.


Android 4.2 should solve the screen lag issue but not even Samsung is offering that for this specific model. Try contacting Samsung and see what they say.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I've had it since Christmas.  The guy at the telus shop where we got it knows I've been having this issue since we got it too.  Samsung says they've never heard of this problem too (typical). 


If you have the one year replacement warranty, go for it. Maybe you will get the current model that is more supported.



Unless you are comfortable with flashing new ROM into the tablet.

generic post since there are tons of posts.


Main section


Search of your Tablet model



The other would be to delete/disable apps that show up as being processor intensive, even at idle.  Check your battery manager screen and see what apps are using too many resources. 


Please let us know if any of the solutions above worked ?