cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No Service - iphone

Rasha
Just Moved In

Hi, 

 

I activated my phone today with telus, it was working fine until a couple of hours ago. I tried rebooting and resetting network settings, nothing worked. 

 

Please help!

 

Rasha

4 ACCEPTED SOLUTIONS

Pamely
Ambassador
first try to do this:

Go to Settings> General > Reset > Reset Network Settings. Let it reboot by itself and it should be working after you do that.

If it is a pay as you go phone, you might have $0 balance. It could be the reason. if you have a postpaid account, you can try by calling Client Care, and see whats going on. but you should try to do first process prior calling. Hope this will help you.!

View solution in original post

Rasha
Just Moved In

xl
CPU Alum
CPU Alum

Take it back to your retailer and see what they have to say.

 

Is your battery fully charged?

View solution in original post

KittyGumDropz
Leader

Before you take it back to one of the dealers, try to contact Client Care at 1-866-558-2273. The dealers will refer you to Client Care if you don't contact them first because usually Client Care and Technical Support gives the go signal to go to the store.

xXKittyGumDropzXx

View solution in original post

6 REPLIES 6

xl
CPU Alum
CPU Alum

Take it back to your retailer and see what they have to say.

 

Is your battery fully charged?

View solution in original post

Rasha
Just Moved In

KittyGumDropz
Leader

Before you take it back to one of the dealers, try to contact Client Care at 1-866-558-2273. The dealers will refer you to Client Care if you don't contact them first because usually Client Care and Technical Support gives the go signal to go to the store.

xXKittyGumDropzXx

View solution in original post

ET
TELUS Employee
TELUS Employee

Hi, you can always get assistance by reaching @TELUSsupport on Twitter or sending them a private message on Facebook.

Pamely
Ambassador
first try to do this:

Go to Settings> General > Reset > Reset Network Settings. Let it reboot by itself and it should be working after you do that.

If it is a pay as you go phone, you might have $0 balance. It could be the reason. if you have a postpaid account, you can try by calling Client Care, and see whats going on. but you should try to do first process prior calling. Hope this will help you.!

View solution in original post

xray
Guardian

Try removing and reinserting the SIM card. If that doesn't work then try swapping SIM cards with another TELUS phone to see if the problem follows the SIM card.