Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus Wifi Hub USB (white Arcadyan tower modem) Settings


Good Day everyone,


I would like to know if anyone has a manual for this Telus Wifi Hub (white Arcadyan tower modem)


Perhaps someone could guide me in the correct direction. I have the Telus Wifi Hub (white Arcadyan tower modem) and i connected a 2TB hard drive to the usb port. The hub sees the drive and i am able to map it as a network drive. I have been trying however to add usernames and passwords to no avail. I am able to turn off anonymous log in but once i do and i set up the user names and passwords I try to enter the credentials on my pc to map the network drive and i do not have any success with the credentials. Can someone shed a light on this issue? 


Thanks in advance. please also let me know if you require any further information.


Community Power User
Community Power User

The ability to add a network drive through the Arcadyan hub is restricted to a very simple implementation basically a file share for the network. If you want a functional network drive with shares, users, etc., you are wiser to purchase a true NAS. 

If you find a post useful, please give the author a "Kudo"

i appreciate the response. i was able to do a few extra things like sharing specific folders and so on. i will continue to try to use the NAS settings. If i do come up with anything decent i would be more than happy to share. 


Thanks again


I am trying to connect a USB drive to the same Telus Wifi Hub, but I can't seem to get it to appear as a network drive.  The hub recognizes the drive, and the Media Server setting and FTP Server settings appear to work fine.  But the File Sharing Active setting does not appear to do anything.  How were you able to map the USB drive as a network drive?  Did it take any additional setup?  I'm fine with anonymous login.

Hi @Tuba,


please change the netbios name to something that is easy to type. once you have done that you have to go to your PC and turn on file sharing across your network. Once this is done you should be able to "Map your network drive" in this pc. once that comes up use your netbios name with \\NETBIOSNAME\USBDEVICENAME\SHAREDFOLDER. if you are sharing the entire USB device then you only need to add the netbios name.


If however you cant find the netbios name you can simply use \\IPADDRESSOFYOURROUTER\ and that should direct you to it


if you are on MAC you need to add a server and do a stmp:\\NETBIOSNAME to add it.


let know how you get along and if you have any further questions.

I tried changing the netbios name to something very simple and made sure the workgroup name is the same.  I'm using a Windows 10 PC.  I checked my network and sharing center and turned on sharing for all networks.


When I try to access \\NETBIOSNAME with or without subfolders, I get "Windows cannot access \\NETBIOSNAME" message.  Same thing if I use the router IP address.


Very strange, there are so few settings to set up in the router settings, but it just refuses to work.

if you open up a command prompt and type "ping NETBIOSNAME" do you get a reply?

Yes, I get a reply from the router IP when I ping the netbiosname.  

Open: Start menu > in search type: Run ; press Enter > type: optionalfeatures ; press Enter > search for: SMB 1.0/CIFS File Sharing Support > Expand view > Check SMB 1.0/CIFS Client + SMB 1.0/CIFS Server > click OK > restart computer

This process worked for me, I managed to get the drive to show up on all 4 pc's on my network after I did this.

SMB 1 is not safe. The protocol is over 30 years old and was developed when network security wasn't much of a concern. If you enable SMB 1 on your client devices be aware that you are at risk if you connect to another network.


Why is it being used on these routers? It's probably because implementing SMB 2 or higher would use up too much resources. It's a router first so priority of resources should be for those functions. As the saying goes, a jack of all trades is a master of none. I wish they would remove file sharing from routers as it inevitably causes more problems than it solves.


If you need network file shares you should get a device built for that purpose. Even the cheapest network drive will implement SMB 2.0 or higher and won't impact functionality/performance of your network.


I'm having exactly the same problem here. What's strange about this is that my TCL TV is able to see the router's DLNA server, and all the folders and files on the external drive which is plugged into it, and play them via its Roku Media Player - which did not ask me for a username and password.


I'm curious as to how you managed to map your network drive; on my PC, in Network, when I right-click on "Telus" (the router name which is displayed), there is no mapping option, and double-clicking on it brings up the credentials dialog, which does not accept any of the credentials I've set up on the router. 


If I set the router to allow anonymous logins, it becomes unavailable on the network.


I guess there may be a NAS in my future ...

*UPDATE* -- I set up an FTP connection and that did the trick.