cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus Wifi Hub Admin Page Issues

perfectmfg
Just Moved In

Hello. Hope you all are doing well. I am having issues on the Telus Wifi Hub Admin Page. Particularly in Wifi section, every tab ie General Setting, WLAN 2.4.ghz and so on, I am unable to click on save settings. Everytime I hover the mouse on it or click it, I get javascript message as seen on bottom left of the screenshot. So basically I am stuck on the default settings. I spent 1.5 hours on phone with tech support yesterday. All he could remotely do for me was change the wifi ID and password to my preference. Unable to change mode, channel and bandwidth. Anyone having this issue?

 

Tried it on laptop with Windows 11, Microsoft edge and google chrome. Also tried it on desktop with windows 10, Microsoft edge and google chrome. same issues. 

 

I think this issue started since they (i think) did a firmware update 2-3 weeks ago. Everything was working fine before that. Telus is sending me a new WIFI Hub. Hope that resolves it. 

 

Any suggestions?

 

Telus Wifi Hub screenshot.jpg

2 REPLIES 2

oddchecksum
Neighbour

Did a new router/hub resolve this?  I'm noticing a similar issue with other settings pages.

It sure did. So far no issues.