Showing results for 
Show  only  | Search instead for 
Did you mean: 

My Wi-Fi App - can't view network devices


After updating My Wi-Fi App when I click on Network I receive two error messages:

- "For iOS 14 and above, Local Network access must be ON for My Wi-Fi app to see and manage any network devices" 

- "You must be connected to your home network to add, view, and manage boosters".


My local network access is On, I have restarted my boost network and Wi-Fi Hub, and tried to reinstall the app.




Have you tried restarting the phone?

I just checked my app, it works fine. Could also try logging out if the app, restarting the phone and sign back in.

I tried to log out of the app and restart the phone with no success.  I also deleted the app and reinstalled it on my phone.


I receive a message that I have no boosters and if I try to add a booster it says that "This feature is only available when you're connected to your home Wi-Fi" even though I am connected to my Wi-Fi.

Community Power User
Community Power User

I had issues with the My Wi-Fi app yesterday. It would not see any devices on my home network. Today it's working fine. Possibly an issue on Telus' end that's been resolved? Give it a try now and hopefully it works as expected.

The app still says I have no boosters connected and that I am not connected to my home Wi-Fi.

How did you delete the app? You need to “offload” the app first in settings before you hit delete. This way you delete the “documents and data” for the app, thereby starting with a clean install next time. Otherwise, when reinstalling, it puts all your settings back in place, and if they weren’t working, the frustration as well. This is assuming, by your username, your an Apple user like me. Android should just delete all data I believe.

I am not sure what you mean by "offload" the app in settings.  I removed the app from my iPhone and selected Delete App so it deleted all of the information and the app was completed removed from my device.  


When i reinstalled the app i had to re-enter all of my information, but the app still does not recognize that I am connected to my Home Wi-Fi.



Okay. In the app settings under the “settings” icon, are local network access and cellular data on?

If you try surfing in your phone, does that work with your modem?

I have to ask, it’s gonna sound stupid, but your not on cellular data when trying to connect? (Not trying to insult)

Do your boosters have the blue light on them?

Can you see your modem in the app?

Just had an idea, not sure how much you’re going to like it. Have you done a hard reset of the modem? Holding the little red button at the back for 5 sec, that’s all I got.

Local Network Access and Cellular data is on.


I am able to access my Wi-Fi on my phone and can surf the web.


Blue lights are on all boosters.  I can see my modem in the app.


I have powered off and done a hard reset on my modem and booster several time to no avail.

Then, unfortunately, the last step is to reconnect your boost devices one at a time again. Make sure before you unplug them you reset them. Or there’s always tech support.

Just Moved In

i'm having the same problem. I had no issue originally setting up the boosters. Not sure if it's because i'm ios 15.6 beta though.    Show's no boosters, and when i click add i get the "this feature is only available when you're connected to your home wi-fi"   .. which i am. Restarted all my boosters too and made sure the settings for App has "Local Network"  set to ON.

Community Power User
Community Power User

I just installed the latest Telus Connect (formerly My Wi-Fi) and it now says no boosters. Prior to this it was showing my booster. Also having issues showing wi-fi traffic.


Likely will need to wait for an update of the app.

@FuzzyLogic , were you able to get this resolved?


I am still having issues with this, ugh 😞

Nope. Gave up

Community Power User
Community Power User

The current version of Telus Connect that I have on IOS is showing my Boost Wi-Fi 6 device. App version is 5.10.1

Just Moved In

I have the same issue? Still no update from Telus?