Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internet loading only some pages, no internet access unless reconnect.

Just Moved In
Anyone else having consistent issues with telus internet? I've gone through many routers in my time at this place, and eventually the same thing always happens

1. On my phone, and laptop, As soon as I'm out of range of my wifi and come back into range, my wifi reconnects, but without internet access, unless I tap "forget network" and retype my password. Sometimes I have to repeat this step 2 or 3 times before it shows internet as connected.

2. When the internet connects, it only allows me to access some websites, or parts of websites. For instance, Crave loads up, but without any pictures, I can hover over blank spots on the page, and it shows me the show title, if I click, it leads me to another page with more information, still no pictures, and won't play the video

YouTube and anything Google or Facebook ALWAYS loads perfectly fine, but simultaneously, I can't load the Telus website, or any website that isn't owned by Google. So my own website won't load, but loads on phone data fine, same with AudioKeychain, Spotify, Apple Music, Tidal, Steam, Discord... all of these load on phone data but won't on my wifi.

Meanwhile Instagram, Facebook, Whatsapp (program) YouTube, drive, Google, and pretty much every other major companies website runs without a flaw.

3. (Not an issue but an explanation)
I am not the account holder on my internet account, it's my landlord, and therefore when I call telus they can't help me, and between my landlords busy schedule and mine, it's usually 1 whole week of back and forth, just to A) be told there no problem at all, or B) have a technician come in and replace everything. To have the EXACT result.

I'm not dumb when it comes to this stuff, I've worked as an internet technician for Roger's, and have been many people's Go-To guy with this stuff for many years. I've logged into my router to check that everything works, and everything seems to look perfectly fine. I've performed probably Hunderds of factory results as well, with the same result.

Has anyone else on here faced the same issues? If so, I'd love to know what worked, what didn't, or maybe some of you have some helpful tips!


Where is the router located relative to your suite? Are there WiFi boosters?

Do you have physical access to the router in order to try using an Ethernet connection to see if the issues are WiFi related or not?