cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

IPv6 with WiFi Hub in bridge mode

foobar
Just Moved In

I need to be on an IPv6 network to do work from home so I just got fibre installed today. Everything is working great out of the box with the white garbage can router. Using https://test-ipv6.com/ I can see my external IPv6 address, able to connect to my work's IPv6 only test server. 


Next, I attempted to connect my Netgear Orbi router to the white garbage can router and turned it into bridge mode. Everything works fine in IPv4 mode. When I attempted to turn on IPv6 via the WAN DHCP mode I got nothing back except the IPv6 DNS addresses. 

 

Any tips on getting this to work will be greatly appreciated. I do not want to be stuck on this white garbage can.

 

 

4 REPLIES 4

foobar
Just Moved In

Well. A whole night of debugging and reading. I have it working. I'll leave the notes here in case anyone wants to get it working with their own router. All the details are available here: https://forum.telus.com/t5/Internet-Home-Phone/IPv6-connectivity/td-p/3521

 

The big gotcha is this note.

2. If the device does request both an IA-NA, and an IA-PD in the solicit message, then it must conform to RFC 7550. We are not using IA-NA so in our dhcp Advertise message there will be a NoAddrAvail message for the IA-NA, and a prefix for the IA-PD.

Most devices out there, including pfsense will issue IA-NA, follow by IA-PD request messages. As noted at the bottom of the thread. Telus is ignoring NA for "security" reasons. Which I don't want to debate about but it's questionable at best. 

 

If you have a Netgear router, you can get to the debug page by adding /debug.htm where you can activate Telnet to get into your router. Once you are in your router, open up

vi /etc/dhcp6c.conf

You will see the sequences for requesting IPv6. 

interface brwan {
        send ia-na 1;
        send ia-pd 11;
        request domain-name;
        request domain-name-servers;
        request ntp-servers;
        request sip-server-domain-name;
        request sip-server-address;
        script "/etc/net6conf/dhcp6c-script";
};

id-assoc na 1 {
};

id-assoc pd 11 {
};

You will need to disable send ia-na 1;

 

That will do it.

Hey @foobar Any suggestions about how to do this on an Asus GT-AX11000 router? Having the same issue

198SIX
Neighbour

Hey @foobar just got the Acadyan AC Fibre Modem - how did you put it into bridge mode??? Can't seem to find guidance online and not seeing it in the modem/router options on 192.168.1.254.

 

Thanks

NFtoBC
Community Power User
Community Power User

See this reply!

NFtoBC
If you find a post useful, please give the author a "Like"