Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug: Telus My WifiGuest activates Guest network without password


Here is the freebie for devs. Let me know once fixed or if there is a workaround. Got another Guest Wifi bug will report once this is fixed.


I got the Telus Wifi Hub running on Fiber optic network. I used Telus My-Wifi app (latest iOS app) to activate guest network by toggling the 'Guest Wi-fi Enabled' to green and entered a new password. It activates the guest network but makes it as a open free network. Basically any device can join the guest network without any password. This defeats the security purpose. To test it out whether the App is caching this, I completely deleted the iOS app and reinstalled the app. It seems to always keep the toggle on. Not sure if I can trust guest Wifi (and its main Wifi might be hackable as well) will be secure as any device can connect to it.


Community Power User
Community Power User

By enabling the guest network you are making a change to the router. Removing the app and reinstalling will not change that.


You can modify the password by using Edit for the Guest network in the app.


More here:


Create a guest network (Actiontec T3200M) (

Looks like I didn't make it clear. The issue is if I activate the guest network with a customized guest password using the Telus MyWifi app, it still activates the guest network as the open network meaning without any password any device can join the guest network and that is the issue. 

What if you log on to the router via browser and set the guest network password, does it behave the same or does it turn on the security?

I can set the Wifi Name but it displays a hard text of 'Open System'. I don't see any way to set the password via browser. See SS. The router is Cylindrical Wifi-Hub (ARCA). I also had a telus technician to walk this through, according to him this seems a weird issue, IMHO a security issue from Telus itself better escalate it before its too late




Do we have any support takers for this open security issue? 

The TELUS Neighbourhood is not a support line. It's a discussion forum for TELUS customers. If you need to open a support ticket you need to contact TELUS technical support.

Community Power User
Community Power User

Try resetting your router, and setting the guest Wi-Fi through the web interface. You should be able to set a password. 
I see the App as a convenience option, rather than my main means of interaction with the device.


If you find a post useful, please give the author a "Like"

I tried doing hard router reset but it's still the same issue from web interface and app as well.


Do you guys see the same issue on your end? Can you activate guest network from web or app interface and then set a customized guest password and once activated, then the guest network is not an open network meaning when you click on guest Wifi network it asks you to enter the valid password and then when you enter a valid password then only the device can connect to the new guest network. Can you try it and see if the above steps work?

Community Power User
Community Power User

Yes, my guest network was set up through the web interface, and requires a password.


If you find a post useful, please give the author a "Like"

I have the same issue and was hoping you found the solution.


If you did, can you please share it?