cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Blank screens after logging into Arcadyan router

AnotherHabsFan
Just Moved In

I've tried multiple browsers (Chrome, Firefox, Safari) but get nothing but a blank screen after logging into my Telus Arcadyan ("trash can") router. Once, after hitting Refresh, I was able to get a nag screen suggesting a change of admin password, but after hitting Save Changes, nothing. The new changes weren't saved, and after logging back in with the default pw, I got stuck in the same loop. Any ideas?

5 REPLIES 5

FuzzyLogic
Community Power User
Community Power User

Possibly you are being blocked by a browser extension?

 

Have you tried Microsoft Edge?

No browser extensions blocking. It took me a while to borrow a PC with Edge, and it worked -- which is ridiculous, considering what a low market share Edge has compared to FF and Chrome (maybe even Safari). I guess this means any time I want to log into my own hub I will need to borrow someone's PC. Sigh.

Edge is available for pretty much all the major platforms. I've rarely had issues and when I did they were resolved with the next update.

xray
Guardian
Try clearing the browser cache in Chrome. If the router had a recent update it's possible the browser cached some script files from the old version.

NFtoBC
Community Power User
Community Power User

I’ve had no issues with Safari. As indicated by others, I suggest looking to your browsers as the issue, rather than the router.

NFtoBC
If you find a post useful, please give the author a "Like"