Roaming...

Reply
Highlighted
Darkbob
Connector

So I'm in the US.  I've got the CanadaUS plan so my roaming is covered.  I'm signed into AT&T (Telus roaming partner for Arizona I guess).

 

Now the problem.  EVERY single time I make a call I get a pop-up asking me a stupid question.  Home country or Roaming country?  (This is with a Samsung Note 9 running whatever the latest Android OS is out there and using stock dialer).

 

Both numbers are the same except for the + at the front.  I mean I get I'm in a foreign country that's getting more foreign by the hour but it's still just the USA.  Maybe Telus/AT&T don't know Canada and the USA both dial with a 1?  So annoying. 

 

Anybody ever seen anything like this?  How the heck do you turn it off?  HELP!!

 

roaming.jpg

Most Helpful
Darkbob
Connector

Ok.. found it.  Figured I'd post it here in case it helps someone else.

 

This is for Android only - no idea if it's even an iPhone issue.  Also it only works for Canadians using Telus who are roaming in the USA with the latest Android OS (whatever it's called... Jelly Doughnut?  Maple Dip?  Twizzler?  No idea what it's called.  But Android 9 I think).  It may only affect you if you are on AT&T but I can't verify that.

 

First you bring up your dialer like you are about to make a voice call.  Next you touch the 3 dots in the top right.  Next you touch settings.

 

Look through your settings for "Roaming Assistance".  (which is misnamed because it's of zero assistance!)  You will see 3 options - "Auto Select Country", "Always call roaming country" and "ask for each call". 

 

Your phone will probably be set to Auto Select Country which certainly sounds like the right setting but counter intuitively this will actually activate the "ask for each call" option.  No idea why.

 

Change your setting to "Always call roaming country" and life will be sweet again. 

 

Not sure if you have to change it back when you return to Canada.  

 

Best of Luck and hope this helps.

Darkbob
Connector

Just wanted to log in and thank MY SELF for answering this question.  I recently wiped my phone and powered it back up to find this problem.  Again.  Worse, I forgot I ever had this problem in the past and I totally forgot the solution.

 

So I googled.  And found this thread. 

 

I read the answer and it all came flooding back.  Seems I'm the only person to have ever solved this issue.  Perhaps I'm the only person who has ever had this problem? 

 

Either way, I found my answer to be incredibly helpful.  I wish I could send my past self a gigantic high five for fixing future self's problem.  Well done - past me.  Smiley Happy

Darkbob
Connector

Oh just a quick update to the instructions now that there's a new Android update out...

 

1)  Bring up dialer

2)  3 dots top right

3)  Other call settings

4)  Roaming Assistance (Note:  Does not appear on all phones)

5)  Select:  Always Call Roaming Country

 

I'm thinking this comes up only on Telus branded devices with Telus ROMS but chances are if you don't see this option you also probably won't have the problem.

BillTelusCust
Ambassador

I always put all my contacts in "E.164" format, which is the plus sign, country code, etc.  This works everywhere and is why I don't have problems.

 

Putting someone as a 1604 nxx-xxx number when you live in Ontario will work when you are in Canada, but NOT when roaming.  Using +1 604 Nxx-xxxx will work everywhere.

 

 

xray
All-Star

Roaming Assistance is a Samsung dialer feature not an Android feature. If you don't have a Samsung phone you probably will never encounter this problem. I've never had any issues dialing from the US on my Android phone, with or without the +.

BillTelusCust
Ambassador

The point is that if you don't use E.164 formatting for telephone numbers in your contacts, then SOMETHING is going to have to fix it, whether it is "Samsung roaming assistance", some other program, the foreign carrier carrier or manual input.   If you (and others) want to completely avoid such problems, E.164 is the way to do it.  The "1 and the area code and number" without the plus sign might well work in the USA and other parts of Canada since the country code is the same as the long distance access code, but it is not going to work if you put numbers for other countries in this way - OR happen to call from other countries that are not on the North American numbering system.

 

Others read these forums to gain knowledge and I hope this saves someone this type of problem in the future.

 

Darkbob
Connector

In my case I am dialing a number that isnt in my contacts.  I am in the USA.  I am dialing Canada.

 

I type in 1–555-555-1212.  

 

I see a weird and useless pop-up (see above).

 

But my solution (also above) fixes it.

BillTelusCust
Ambassador

You "fixed" it for the USA.

 

And you seem to have absolutely no interest in the way that fixes it for everywhere.  Don't deny others the chance to see the complete fix.

Darkbob
Connector

So what kind of complete universal fix would you suggest?  You cant put every number on earth into your contacts. Even if you did it wouldnt work for USA to Canada calls - all my contacts are already in the proper format and the problem persists.


@BillTelusCust wrote:

You "fixed" it for the USA.

 

And you seem to have absolutely no interest in the way that fixes it for everywhere.  Don't deny others the chance to see the complete fix.