iPhone: Receiving texts from another iPhone

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

KittyGumDropz
Leader

This can be fixed in one of two ways:

  1. Go to Settings > Messages > Send & Receive and uncheck the email address shown under "You can be reached by iMessage at" on all of your devices.
  2. If you want to continue to receive iMessages at this email address on one of your phones, on the other two go to Settings > Messages > Send & Receive, tap the Apple ID at the top, sign out, then sign back in using a different Apple ID (so all three phones will be using a different Apple ID for iMessage).

 

Note: you can continue to share an Apple ID for purchasing from the iTunes and App stores.  It does not need to be the same as the ID you are using for iMessage, FaceTime and other services.

xXKittyGumDropzXx