cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why are Optik TV Digital PVR boxes so bad?

ScottW
Neighbour

This is my second box. Both exhibit the same issues.  Non 4K ones were fine for years.

 

Freezes 3 times a day.  No response to controller input.  Hard reset (unpluging the unit) required.

Cables are fine.  Box resolution has been set to 1080p as I thought the 4K setting was causing this.

 

After reboot the setup screens can vary.  "Initializing", or some Accent setup screen I have no idea what for.

 

I have no solutions other that to wait for a better quality device to be made available by Telus.  Or go back to an older model.

Please consider improving the quality of these devices as they are what is consumer facing.

 

3 REPLIES 3

xray
Guardian

All 3 of my 4K Optik boxes have been running fine since they came out years ago. 2 of the 3 are set to 4K output.

 

When you installed the replacement did you use the new power supply that came with it or just swap the boxes?

Perhaps you have some house power instability. Are you using a good quality power bar?

 

WestCoasterBC
Community Power User
Community Power User

I haven't had any issues you describe with my arris 4k boxes for the last 3 years all work flawless. Which brand do you have arris or technicolor? Freezing as in the box locks up or digitizing?

pbsfan
Connector

Is your boxes ethernet wired to the Telus modem, or relying on wireless connection?  I had problems with wireless being unstable and it was solved by using a moca device to connect to the Shaw cable outlet near the box.  Of my three, two are wired and one closer to the Telus modem is using WiFi.  I do find I have to reboot that one every once in awhile, since it seems to lose the connection.  I live with that, since it's in a bedroom location where it isn't used all that often.