VPN and cellular bands

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Majesty00
Resident

Hello,

 

I've been plagued with a problem for a while now...

 

I have a personal VPN at home on my Synology NAS. I also own a Google Pixel bought from Telus last year. Before using thay phone, I could connect to my VPN without any problems (using a Nexus 5X) and access everything behind my VPN. With my Pixel, I can still connect to my VPN, but I can't access everything on my VPN. I can ping my devices, but I can't connect to the NAS services (like DS File, or DS Get, if you're familiar with that NAS).

 

While trying to find the cause of this, I've tried something and found something. When you dial *#*#4636*#*# in your phone app, you get the testing "secret" menu. In that menu, inside Phone Information, you can force the band your phone will use. I've tried a few and tried my VPN afterwards. When I select WCDMA (instead of LTE/CDMA/UMTS auto (PRL)), I can access my VPN and ALL the services behind.

 

Why?!?!?!? What is happening??

 

I hope someone will either be able to tell me why or tell me how to fix my problem.

 

Thank you!

johnevansab
Resident

When you connect to your synology are you using a FQDN - such as NAS or SYNOLOGY?  Have you tried using an IP address of the NAS instead?  

PatLaf
Resident

After doing some troubleshooting, I realized i have the same issue as you. Same deal, I have a VPN to my house to access various things on my network. If I connect with my phone on Rogers, no issues. If I connect over Telus, the connection establishes however data transfers don't work. Changing to WCDMA (4G instead of LTE) gets it working but at a lower speed. This shouldn't be happening. Is there anyone from Telus on here that can chime in as to why this is happening? I'm on an S7 Edge.

Most Helpful
PatLaf
Resident

Just an FYI to anyone else that may be having this problem. I'm using OpenVPN. I had to change the transport to use TCP instead of UDP and changed the MTU to 1300 to ensure I'm not getting any fragmentation. Everything seems to be working now even though I shouldn't have to do anything like this to get it working.