cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: "No Service" on iPhone

ET
TELUS Employee
TELUS Employee

Try this : go to Settings, General, Reset and Reset Network Settings.  I'm sure this will be really helpful.

1 ACCEPTED SOLUTION

komori
Neighbour

Thanks everyone for the suggestions. I had a livechat with a Telus rep who pointed out that I needed to turn 3G data back on - I guess I had turned it off at some point while traveling. D'oh! So, in the end it was a matter of me overlooking an obvious setting rather than an evil plot by Telus to deprive me of cell service. 

If anyone else has this problem after traveling out of their home province, here's the checklist: 

- Ensure that phone is not in "Airplane" mode

- Try resetting network settings (under Settings/General/Reset)

- Try removing and reinstalling SIM card (This was required once before in the same situation)

- Ensure that 3G is "ON" (if you have a 3G phone)

- Ensure that "Carrier" is set to "Auto" (or alternatively, you may select Telus if it shows up as an option after Auto is turned off)

I think that's it - good luck to others if you run into this problem!

 

View solution in original post

1 REPLY 1

komori
Neighbour

Thanks everyone for the suggestions. I had a livechat with a Telus rep who pointed out that I needed to turn 3G data back on - I guess I had turned it off at some point while traveling. D'oh! So, in the end it was a matter of me overlooking an obvious setting rather than an evil plot by Telus to deprive me of cell service. 

If anyone else has this problem after traveling out of their home province, here's the checklist: 

- Ensure that phone is not in "Airplane" mode

- Try resetting network settings (under Settings/General/Reset)

- Try removing and reinstalling SIM card (This was required once before in the same situation)

- Ensure that 3G is "ON" (if you have a 3G phone)

- Ensure that "Carrier" is set to "Auto" (or alternatively, you may select Telus if it shows up as an option after Auto is turned off)

I think that's it - good luck to others if you run into this problem!