Showing results for 
Show  only  | Search instead for 
Did you mean: 

Huawei honor X2(GEM-703L) can not make a phone call but can surf internet and SMS.

Just Moved In

I have a new Huawei honor X2(GEM-703L) ordered from China.

It's unlocked for sure.

gsmarena's shows:

2G bands GSM 850 / 900 / 1800 / 1900 - SIM 1 & SIM 2

  HSDPA 850 / 900 / 1900 / 2100

4G bands LTE band 1(2100), 3(1800), 7(2600), 38(2600), 39(1900), 40(2300), 41(2500) - GEM-703L

It shows Telus's signal and I can receive and send SMS and surf the internet perfectly when I insert my Telus sim card. that means registered successfully.

however, I cannot dial out any phone # expect voicemail. I cannot received any phone call from others and they transfer to voicemail automaticly. 

I used a Koodo's user. because Koodo and Telus are the same. so it also cannot dial the phone or receive a call but can surf internet and sms perfectly. 

there are two sim card slot it have. I have tried two of that. it doest works.

clicked a contact I selected. It transfer to dialing screen and screen gone immediately like nothing happened. If voicemail, It will keeps the dialing screen and connected.

when I inserted any other carrier's sim card like Bell, and Rogers, they was working fine for all the function including phone call, sms and internet. that means the phone is OK.

I tried to call Customer service and the sales rep said I can go to store to change a new LTE sim card. however, Even Though I change a brand new LTE sim card, the problem still on, I still cannot dial the phone call.

when I insert my telus sim card into my old samsumg note3, It's OK with all functions...

anyone can help?


Community Power User
Community Power User

There are likely some missing settings. Probably the APN ones. Call Telus and get those settings. You'll have to find the correct spot to put them in your phone settings.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂