Showing results for 
Show  only  | Search instead for 
Did you mean: 

PureFibre ipv6 own router issues

Just Moved In

I have PureFibre with my own router plugged directly into nokia ont. this works fantastic with ipv4, 0 issues! until I enable ipv6 in my router. It's able to get the ipv6 no problem and it works for a while but 30-60 minutes later my connection goes red. I need to reboot the nokia or disable ipv6 in my router. 


I have tried this with 2 of my routers both ASUS an AX11000 and XT8 . I have tried with multiple versions of the firmware, all with exact same results


If I use the Telus Router ipv6 works fine, if I connect my router in bridge mode exact same result. but if I connect my router in non bridge mode ipv6 works as expected (but double nat) and of course I do not want to use their router just so I get ipv6. 


Connection Type: Native

DHCP-PD: Enabled

Auto Config Settings: Stateless

Connect to DNS Server Auto: Enabled

Enable Router Advertisement: Enabled


Any one have some thoughts?



You need to send a periodic router solicitation every so often to keep the route alive. Telus aren’t obeying the RFC on this and as far as I’ve seen only a couple of other ISPs in the world do this, so it doesn’t work with most routers out there except the newest Telus provided ones. If you can add a cron job and build a binary that runs on your router fixing this is pretty easy.

Edit: this only applies to some Telus neighbourhoods. I think most don’t have this behaviour but it does happen in north van and parts of Surrey I think.

I can run CRON jobs in Opnsense but am not to sure where to get started with this. Do you have any resources you could point me to so I could fix this issue?

On opnsense or pfsense you can run “/sbin/rtsol -a”, or replace the “-a” with the interface name for the WAN (igb0 or whatever it is). If you do this every 20 minutes or so it should keep the route active.