Showing results for 
Show  only  | Search instead for 
Did you mean: 

OpenDNS for Telus WiFi Hub Arcadyan


I used the default options for setting up the hub to use OpenDNS but its not working.


OpenDNS says I'm connected and using their DNS servers but I can browse to adult websites without being blocked, which means the hub is somehow defaulting to using Telus DNS servers.


I even tried setting it up for IPv6 but that didn't help.


Has anyone had luck setting this up properly? Tech support tried to tell me my Telus WiFi app could be configured with parental controls and website filtering but it can't, at least for this hub. Any advice would be appreciated.


Friendly Neighbour

Anyone know if Telus redirects all Port 53 traffic to their own servers? It sounds like that's what is happening. If so, do some research on installing dnssec and dnscrypt on your local device(s) to solve it. For example, a firewalled filtering box called a pi-hole does that sort of thing.


Thanks for the heads up and I hope you find a solution you can share here.