cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cant Connect to Any Service via WAN but Can Connect Via LAN

ExquisiteToast
Helpful Neighbour

I set up an Apache server and it is working fine if I connect from LAN, but if I try connecting from my domain name (I'm using Freenom for the domain name) or WAN IP it just times out. Same thing with Minecraft servers, Terraria servers, FTP and SSH.

1 ACCEPTED SOLUTION

If the two IPs match then you have a public IP. No need to bother tech support for that now. As I mentioned in my first reply to you, you will not be able to connect to your WAN/modem IP or domain from a device on your local network to test the connection. You'll need to either be on a VPN, cellular, or another internet connection. Easiest to test would be the webserver.

 

First ensure the computer hosting the server has a reserved IP. (Telus router > Advanced Setup > DHCP Reservation)

Then go under Firewall > Port Forwarding and start forwarding everything to that device.

 

I have found some ports when forwarded just don't seem to be accessible from an outside connection. 80 works. One of the three ports associated with Team Speak won't open/forward properly. Telus does have a very small number of ports blocked including FTP (21). Those blocks shouldn't affect the majority of apps. I've been using https://portchecker.co/ test if the ports are showing as open for my connection. The server has to be running before the port will show as open on that site.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

View solution in original post

16 REPLIES 16

Nighthawk
Community Power User
Community Power User

If you have another device at home, run it on cellular or a VPN to test the domain. You will NOT be able to connect to your own IP from your home connection directly. 


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I used a VPN and tried connecting to the web server running on my server (I disabled the Ubuntu firewall for the test) and it still timed out. I can't check cellular at the moment but it'll probably be the same.

rc
Rockstar

Can you ping your WAN IP?

 

Is your WAN IP address a "private ip address" ? If it is, it could be behind a carrier grade NAT, which can block port forwarding.

ExquisiteToast
Helpful Neighbour

I cant ping my WAN IP and I'm not sure if its private or not. Is there any way to check?

Compare the router WAN IP address, obtained from the router home page, with the addresses identified in this wiki

 

https://en.m.wikipedia.org/wiki/Private_network

 

ExquisiteToast
Helpful Neighbour

Yeah my WAN IP fits in the carrier-grade NAT scenario. Is there any way to bypass the restriction on port forwarding?

You could try calling TELUS and ask them to move your connection to a public IP address as you require it for port forwarding.

 

Since TELUS does not support running servers on a residential service they may try and upsell you to a Business Internet service.

 

 

ExquisiteToast
Helpful Neighbour

Alright, I'll go call them right now.

ExquisiteToast
Helpful Neighbour

I just finished the call with Telus. They said they changed my WAN IP after resetting my router. I told them it is still the same and they told me to reset it again and restart my computer. I did that both and my IP is still the same and port forwarding still doesn't work.

The person incorrectly assumed that rebooting would result in a new address being assigned. This will not happen unless the router was off line for longer than the reservation time. Also this will still result in a private address being assigned

It may be a challenge to get a knowledgeable tech support representative that understands the difference between private and public IP addresses and how to move a router between the two address pools.

You may have to escalate to a higher support tier.

ExquisiteToast
Helpful Neighbour

How can I get a higher support tier? Or do I just have to keep calling Telus until I get a customer support representative that can change my private IP to a public one?

I seriously doubt there is a single customer support rep that will be answering phones that will have the ability to do anything with your IP. It's not something they're going to be trained on either. It's likely several levels above their pay grade and department. Getting one of them to understand what you want is likely going to be the hard part. As mentioned before in this thread, the residential plans are not intended for running servers, it may be an uphill battle to get a public dynamic IP just for that.

 

I don't know the exact criteria for someone to get a non-public IP but if the posts on the forums here are an indication, the power users trying to run servers don't seem to encounter it much. You're sure the "Modem IP Address" you see when you log in to the Telus router does not match the IPv4 address that you see when you check your IP? You're not using a third party router or something else are you?

 


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I have the original router that the technician installed and I just checked and the IP in the router's home page and the website you linked are the exact same.

If the two IPs match then you have a public IP. No need to bother tech support for that now. As I mentioned in my first reply to you, you will not be able to connect to your WAN/modem IP or domain from a device on your local network to test the connection. You'll need to either be on a VPN, cellular, or another internet connection. Easiest to test would be the webserver.

 

First ensure the computer hosting the server has a reserved IP. (Telus router > Advanced Setup > DHCP Reservation)

Then go under Firewall > Port Forwarding and start forwarding everything to that device.

 

I have found some ports when forwarded just don't seem to be accessible from an outside connection. 80 works. One of the three ports associated with Team Speak won't open/forward properly. Telus does have a very small number of ports blocked including FTP (21). Those blocks shouldn't affect the majority of apps. I've been using https://portchecker.co/ test if the ports are showing as open for my connection. The server has to be running before the port will show as open on that site.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

View solution in original post

I gave up after the call with Telus but I just set everything up again (I just added a DHCP reservation for my server and opened ports 800 and 443) and my friend was able to reach my Apache server through the domain. I also used a VPN and I also reached my Apache server. Haven't tried cellular yet, but I hope it also works. Thanks a lot for your help. I don't know why it started working all of a sudden but I'm hoping I wasn't just being dumb sinxe I certainly remember port forwarding port 80 and adding a DHCP reservation when I made this thread.

 

Thanks to @Nighthawk and @rc for helping me for almost a month.

ExquisiteToast
Helpful Neighbour

Just a tip if anyone else would like to have access to their WAN IP when you're on the same network. Get a domain (freenom is a free domain name provider) and use cloudflare with it. Cloudflare will proxy the connection through other servers which will let you access the domain from your own network.