Showing results for 
Show  only  | Search instead for 
Did you mean: 

Playback Error on Laptop

Just Moved In

  Started mid day when the channel I had on went blank and then gave me the "Playback error. Sorry an error has occurred, Please try again".  All channels now say this when trying to watch anything.

   I am using Chrome and have not had an issue watching for quite some time now. I made sure Chrome was updated (it was) and logged out and back into my Telus TV account many times and still get the same thing. i tried it on my phone using the app and no issues, it works fine?

  Please let me know any ideas as I've spend enough time searching here and the net in general trying to find a solution.


Between this and that the set top box freezing and needing a reset about every 5 days (last one was during OT in the hockey game), have to say that Telus TV is far less reliable than others I've had in the past. 



Hey Crash6 - I recommend trying to use incognito mode as that browser will not have any cache or cookies. Please let me know if that fixes the issue