Using 2 routers and IP Address

Reply
Highlighted
Connector

I am posting this wondering how anyone who puts a switch between their ONT and routers manage to get around the issue of only having 1 IP Address? I have internet 150/150 and there's only 1 IP Address provided and I want to use my own router while keeping the Actiontec router for optik tv. 

 

I've notice my router goes down here and there because of the lack of 2 ip addresses I believe but it works for a few days before it goes down. So i'm wondering how some of you get around this.

Highlighted
Coach

Can you check the subnet of the ip address that telus gave you? Another thing you can do, if you are not concern about having two separate public ip address, you can use your own router by connecting it to the router that telus provided to you.

Highlighted
Connector

@linuxgeek What should I look for in the subnet ip address? 

 

I also just switch my setup to the one you mentioned. I see 2 separate IP Addresses on my actiontec and my own router. Would that be consider as 2 IP Addresses? Telus mention they only provide 1 for home users.

Highlighted
Coach

I the actiontec and your router has 2 different public ip address then you have 2 ip's.

Highlighted
Connector

Telus support told me they only issue 1 ip for home services. Would this mean my 2nd router shouldn't work?

Highlighted
Coach

As long as both the routers have 2 separate public ip addresses it should work, unless they blocke the other ip address. Another way to check if how many use-able ip addresses they assigned to you is by checking the sub-net mask of the ip address assigned to you. Check the WAN ip address in the router and see what the subnet is, it should look like this 255.255.XXX.XXX.  Post it here so that we can check it.

Highlighted
Coach

The sub-net mask look like this 255.255.XXX.XXX, you can check it in the router where the WAN ip address is, or if it is not called WAN in the router it is called "internet". Check it from there and post it here.

Highlighted
Connector

@linuxgeek they are both 255.255.252.0

Highlighted
Connector

Good afternoon…

 

I’m following this discussion with great interest. I as well would like to enable a second public IP on my system. Utilizing the T3200M modem/Router in Bridged mode, are we not able to utilize the second LAN port to issue a second public IP address?

 

I was able to utilize the second LAN port on my Shaw modem to facilitate this ability when the modem was in bridged mode…

Highlighted
Connector

 

Am I not correct that a 255.255.252.0 is a /22 network and should be able to issue 4 IP under a Class C addressing structure? There for we should be able to get a second public IP by putting the Telus modem in bridged mode and utilizing 2 of our own routers behind the Telus modem?

Highlighted
Connector

@DrPacman My issue is actually wondering if my own router as a 2nd IP is fine. Apparently telus told me they only issue 1 IP which would be connected to my Actiontec right now. So when I bridge the connection with my own router, my own router would then be the 2nd IP.

 

I had a few issues where I would disconnect and had to reset both routers to get a wan connection again, but my own router would have issues after reset while actiontec router would be fine, so I'm not sure if it is because it has trouble getting a 2nd IP address. Or if it was just my setup before with the switch in between.

 

Using other LAN ports besides LAN 1 on the t3200m I hear wouldn't work on a port bridge as Telus only allowed LAN 1 to work from my understanding.

Highlighted
Coach

Do it this way:

If you are using ONT modem:

From the ONT you need to a have network switch, at least 5 port network switch the smallest that you can buy. Connect the switch to the ONT modem port 5 of the switch. Then you can connect your 2 routers to any of the remaining 4 ports. This of course if the sub-net of the ip address that TELUS assigned to your modem is at least 255.255.255.252, means that this sub-net is allowing you to use 2 use-able ip addresses. To tell you frankly, don't rely on what the technical support from TELUS tells you right away since most of the them are level 1 support and doesn't know everything about TELUS infrastructure. @stinger, yes the ip address of the second router should be fine for as long as the sub-net is at least 255.255.255.252.

Coach

Even if you are connection is not fiber, and you are using t3200m actiontec modem/router, make sure that it is in a bridge mode, then add the switch and the 2 routers connected to the switch.

Highlighted
Coach

@stinger, can you check the sub-net of your connection from TELUS?

Highlighted
Coach

@DrPacman: Once the actiontec is in the bridge mode you can only use one LAN port, that's why you need a switch for the two routers.

 

Highlighted
Coach

@stinger: have you tried removing the optik tv receiver and see if the internet drops?

Highlighted
Connector

@linuxgeek must've got lost with the posts above lol. It is 255.255.252.0

 

In regards to optik receiver, i haven't. It's more of router losing wan connection when i tried it with switch in between ONT and the 2 routers I'm using. But what I didn't do in this situation was set t3200m in port bridge. Could that have been an issue?

Highlighted
Coach

I don't think that's an issue. Try removing the optik receiver first, because I don't know how the optik receiver works since it is directly connected to TELUS network using the physical connection from your house to their CO. To tell you frankly I have 4 routers connected to the NOKIA ONT. And I have no issue at all, I am getting 4 different ip addresses. But it is important that you need to know the sub-net before you can use 2 routers.

Highlighted
Coach

You should be able to use 2 routers base on your sub-net mask.

Highlighted
Connector

@linuxgeek that's good to know you can get 4 routers connected! I take it you use the switch between ONT and routers? Did you turn on port bridge on your t3200m too?

 

FYI, I haven't had an issue since plugging into t3200m with port bridge on. It was noticeable right away something was wrong previously when I moved it once and turn it on and won't connect, then 2nd time it disconnected it just stopped very suddenly. So far so good since plugging directly to t3200m. 

Highlighted
Coach

I actually did not use the t3200m. I use different routers. So probably what you did is what needs to be done so that it will not drop the internet connection.