Home internet disconnected? Potentially due to non-payment?

Reply
Highlighted
Resident

Hello!

I live in a shared house in Vancouver where the landlord takes care of the internet; he is away for the next few months. However, today, my home WiFi (and wired internet connection) suddenly stopped working. I'm fairly technically-savvy; I've power cycled the modem and router several times. I've also wired in directly to the modem and the same issue persists (no connection).

Now, whenever I open a browser on my computer or my phone... the following page appears (see screenshot below). I've never seen this prompt before. Interestingly, when I click either option ('new customer' or 'I already have services')... nothing loads. 

Does anyone have any idea what is going on? The reason I am wondering whether it may have been cut-off due to non-payment is because the issue came out of nowhere + there are no service outages in my area + power cycling the devices didn't do anything. Also, it is possible that my landlord did screw up paying; it wouldn't surprise me.

I'm on hold now to chat with Telus, but because I am not the account holder (I am only a tenant living in the house and the landlord is away)... I'm not sure how much information they'll be able to give me. I really just need to know if it's a technical outage or if it was cut-off due to non-payment (in which case, I can get in touch with my landlord to figure out the payment issue). 

(For what it's worth, the Optik TV box is also stuck on the 'box initializing' screen too.)

Any ideas? Thanks everyone!

ss1.png

Highlighted
Connector

You'll probably need to contact your landlord.

They can add you as a contact on the account so that you can get in touch with Telus in the future.