cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't connect, incorrect login credentials

Qix
Organizer
App not working, tried logging out then back in again, as I've done many times with this app.
Now I cannot get back in, telling me my credentials are incorrect.
This app is quite sad, fix someone?

Edit:
So after being on hold for over an hour with support, I'm told that there is an outage with the app.
Would've been nice if there was just a post about that instead of wasting my time just to be told to wait..
7 REPLIES 7

Sugarhigh
Just Moved In
Same here… app sucks

vancouveric
Just Moved In
Mine not working as well. Hasn’t worked for over an hour. Wondering if anyone is working on a fix.

tporter2u
Helpful Neighbour

Same problem with ours as well! Did all the usual fix attempts but no luck so far.

CGBG
Just Moved In

I just got back in after changing my password. Wouldn't work otherwise. This app sucks in so many ways.

I changed my password and it still won't let me. I'm so FECKING SICK OF THIS APP! I expect MORE from TELUS!

tporter2u
Helpful Neighbour

Resetting the password worked for me! Thanks!

KHR
TELUS Employee
TELUS Employee

Hi @Qix @tporter2u @musicfreakcat @CGBG @vancouveric 

 

We experienced a server outage this evening, and are getting things back up and running, but there may be intermittent login issues which is causing login failures and error messages. Sorry for the inconvenience. If you're still having trouble I'd recommend force-quitting your apps and trying again. Everything seems to be working across TELUS TV Digital Box, Sony TV, Apple TV and iOS for me right now.