Showing results for 
Show  only  | Search instead for 
Did you mean: 

How Do I Access the USB Drive Plugged into my ActionTec T3200M?

Just Moved In

So there are a few posts by people on this forum but no one has given a definitive answer as to how to access the drive I have plugged into the back of my Actiontec Router. Here is what I have tried so far:


I have tried all of this with both a Fat32 thumb drive and NTFS Hard drive. I logged into the router, Advanced settings, Storage Device info. Both drives can be seen on that page, labeling then disk1_1 and shows the space used and free on them.


Then I go to Samba Configuration. I enabled sharing. I tried with the same Admin and password as the router has as well as a different one to see if that made a difference. It did not seem to. They are both on the same workgroup as my home network. I also tried on a Mac and on a PC. Neither can see them on the network. I fought with multiple settings, multiple combinations of configurations and no success. I spent a number of hours into late last night and again this morning on these forums and some of you guys report that it works with Fat32 and another guy said it does work, someone said after firmware 13 he got another actiontec model to work, I thought someone said they were able to stream MP3 but not Flac but I can't remember. Regardless, I can't, for the life of me, get it to work. I also spent time reading the manual, even looking at forums in the States to see if they could help me. Nope.


Finally, after I had no more hair on my head left, I chatted online with an agent from Telus Support named Jordan. Thankfully I didn't have to wait long to get connected. He said the USB is disabled on the Actiontec T3200M. And, thinking it was kind of funny, I quoted The Wedding Singer and said, "Geez, you know that information would have been a little more useful to me yesterday." Then I asked him if he was sure because they were showing up as connected on the modems config page, what people reported on the forums, blah blah like I just told you. And he told me that they have always been disabled since they got the ActionTec. Then I was like.....  "Once again things that could have brought to me attention YESTERDAY!!!!" In all seriousness, if that is true, I am somewhat irritated at Telus for not making that information available anywhere on the site and at the misinformation on this forum from guys who don't actually have a clue what they are talking about and are just looking to get likes for their stats.


But.... I am not 100% convinced that this is a completely lost cause. It sees it on the router. It lets me enable sharing so how can one enable something that is disabled? So I put this question to anyone whom has actually had success getting a USB to work to tell me exactly how they did it, perhaps with what kind of drive, settings, etc. And if not, hopefully, I'll be saving someone else a bit of time (and they won't be bald) and they can simply get a second opinion from someone at Telus support. God bless and hope to see you all at #Shambhala20



What do you mean by "can't see them on the network"?  Do you mean can't see them in Windows Explorer under Network? Or something else?


I have found that often with network attached storage you have to explicitly map a drive in Windows, sometimes even using the actual ip address of the device.  I haven't tried to do this with the ActionTec T3200M yet (just got it two weeks ago).


Ignore the misinformed Telus reps...the USB port is NOT disabled on T3200M.


Try create a root folder named 'admin' (without quotes) on your USB drive first then move all your stuff in that folder re-plug into T3200M and re-enable samba.


You should then be access or browse \\\admin with no issues.


Good luck!

Just Moved In

Yesterday I got T3200M.
During visit of technician, I asked him how to connect USB Drive. He answered: USB port is only for service use....
I check Google and I found info how to connect and use USB drive.
First I connected my 2TB external USB 3.0 drive, and saw it on router, but not saw at computer.
Of course I needed login to router > Advanced Setup > Storage Service > Samba Configuration > File sharing: ENABLE, then enter user name and password YOU WANT TO SET (new one, not user name and password to login to router - you will need it to connect other devices to this drive) If your drive is correct (about this later) you will see: Device name: disk1_1. And last thing: Workgroup: here yon have to enter the name of your network group created on computer. Then APPLY.
I didn't see my USB 3.0 external drive, BUT I tryed with 8GB USB 2.0 pendrive and IT WORK VERY WELL !!!!
You don't need to create any directory - you can do it later.
On your computer best way to find it is search for (usually left lower corner of desktop) \\ (two slashes in address are very important) and that's it. You can see network drive with folder named same as user you set.

You can map this patch and use it as another drive of your system.
Now I have access to this drive from all computers in my network (Windows7 and Windows10) and using Samba service I have access to drive (when I'm at home WiFi) from my Samsung Galaxy S5 - I recommend ES File Explorer.
Transfer speed is OK, I can watch HD movie without any lagging on two different devices.
BUT I DON'T KNOW what is maximum capacity of drive and what kind of formatting I have to use. Now I have FAT32.

With Regards, Zibi.

This method works great.  A couple comments: 


- When you browse the drive over the network, the root will be the "admin" folder.  You won't be able to see anything outside that folder - so I have moved everything into that folder, and it works great.  I'm guessing you could create other shares with other root directories. 


- I have it working with a USB2.0 1TB HDD, formatted in FAT32.