Showing results for 
Show  only  | Search instead for 
Did you mean: 

Home alarm panel not working since switch to Telus


I recently switched from Shaw to Telus. I have an HAI home security system with 6 control panels located throughout the house and garage. Five of them are regular push button control panels and one of them is an HAI Omnitouch 5.7e touchscreen panel at the main entrance to the house.

The touchscreen panel is no longer working. It is stuck at a "connecting, please wait" message. I've reset it multiple times and even updated the firmware but the same thing happens. At first it says "acquiring IP address" then switches to the "connecting, please wait" message and stays there.

The alarm system still works and the five push button control panels still work. I'm able to turn the alarm on and off with the push button panels.

I'm sure the problem has something to do with a new IP address or something since the switch to Telus but I can not get the touchscreen working. If I go to the settings on the push button panels, I can see an IP address that starts with the common 192.168...etc but in the settings on the touchscreen panel it starts with a 169.254...etc.

I thought I might need to forward those ports on the port forwarding options on the Arcadian Telus Wi-Fi Hub, but I can only edit the last group of digits and the first 3 groups are greyed out for the IP addresses. For example it has 192.168.1 greyed out and I can only edit the last group of digits for the IP address.

But...I also haven't forwarded the port with the IP address that the push button panels are showing and they still work. ¯_(ツ)_/¯

Has anyone else run into a similar situation or have any advice how to get the touchscreen working?


Friendly Neighbour

Hi. Former alarm tech here with IP monitoring experience. When you change your ISP you must notify your alarm company. The tech will have to reprogram your system with a new gateway IP address. 

Thanks for the reply.  My alarm is not monitored and the installer is long gone.  I'm on my own here.  I can get to a Network setup tab on the panel and it asks for an IP address, Port, Subnet Mask, Default Gateway and DNS Server.  I don't know how to find any of that info for the panel.  To reiterate from my initial post.  This is an existing alarm that all worked fine on SHAW.  The alarm is still working fine now, it's just this one touchscreen panel that can't connect.  I have to use the other push button panels or the app on my phone to control the alarm.

Community Power User
Community Power User

Entering the IP address should allow the panel to gather the other info. The 169 address simply suggests the panel can’t connect to your router’s DHCP server. Is the panel wired, or wireless? If wireless, how is it connected to your Wi-Fi?


DNS Server, and Gateway, are listed in the Admin >Overview >Network Screen for your setup.

Subnet mask is likely

If you find a post useful, please give the author a "Kudo"

Entering didn't work.  Why did you suggest that number?  Where did that number come from?  Entering the IP address that I found in the setup of the push button panels doesn't work.  The panel is wired via ethernet and confirmed to be connected.  I also entered all the info I found in the Overview > Network Status page for the Gateway and DNS.  I've port forwarded the IP address & port from the push button panels on both TCP and UDP.  I can ping the push button IP and the Gateway IP and I get a return but I get nothing from or the DNS IP.  I've tried so many numbers over the last week, it just won't connect.