Unusable for 3 days on Apple TV; can't log in

Reply
KLJ
Resident

I had PureFibre installed on Saturday and had Pik TV added to my services. No problem, used it on Sunday on my Apple TV, worked fine. Sunday night and onward, nothing but issues. Sunday night, when I went back on, it was stuck on the black screen with Pik TV on it. After troubleshooting, nothing worked. I finally got through that on Wednesday, but since then, I can't log in. It says my credentials are invalid and to reset my password if I've forgotten. 

 

The password and I've confirmed this, is the same one I use for My Telus, the same one I used to log in prior. I reset my password, to be sure. Same issue. It takes forever to load and then tells me that the e-mail/password is incorrect and that after 5 attempts, my account will be locked for an hour.

 

Super frustrating. I've tried to call in for support, and have been placed on hold, which is fine, only to be disconnected not once but twice when I reach an agent. I've waited over an hour and a half both times. 

 

I want to cancel this service at this point, but I can't even connect with someone to do that. I can't use the service. I can't use it on my iPhone, my partner tried on his iPad, and the link that Telus provided for the browser doesn't work, either. I'm using Telus' home services, internet is working perfectly. 

 

Just stuck on what to do at this point, besides continuing to attempt to call, and hopefully be connected to cancel. 

KHR
TELUS Employee
TELUS Employee

Hi @KLJ 

 

Did you do the troubleshooting yourself, or was it tech support? 

 

Your issue on Apple devices looks like it may be related to SSO. I'd try disabling the TV provider setting (Apple TV home screen --> Settings --> Users and Accounts --> Apple TV Accounts --> TV Provider and then turn off 'Allow TV Provider to Access'. Your old password might be cached and this is what's causing the hangup that you're seeing. Same process on iOS: Settings --> TV Provider, turn off 'Allow TV Provider to Access'. 

 

The URL for the browser version is telus.com/watchpik If you are not able to log in to this site on Chrome, Edge or Safari on a laptop or desktop with the credentials that work on telus.com/mytelus or on the My TELUS app, then there may be an issue with your account that needs to be resolved by an agent. I'd recommend trying to chat in first thing in the morning to avoid higher call/chat volumes.