Subscribed channel not showing in Guide

Reply
Piky
Neighbour

I am subscribed to Chek TV Channel 121.

When I press the Guide button on the PikTV remote, Channel 121 is not listed.

If I select 'Show Me' at the top of the left panel on the Pik TV screen and select 'My subscribed channels', Channel 121 is shown in the guide, but the next time I display the guide, 'Show Me' has gone back to 'Playable on this device'.

Channel 121 is always shown in the 'Home' list of channels.

How can I keep 'My subscribed channels' selected at all times in 'Show me'.

KHR
TELUS Employee
TELUS Employee

It looks like there might be 2 issues:

 

1. Your Pik TV box isn't recognizing that you're on your TELUS home internet. Chek TV is only available when connected to your home internet, but is included in all Pik TV subscriptions for applicable locations. All of your 'My subscribed channels' should also be 'Playable on this device' when connected to your home internet. I'd suggest disconnecting from Wifi or ethernet and then rebooting your box (Android TV home --> Settings --> Device Preferences --> Reboot). After it reboots, re-connect to your Wifi/ethernet. This should reset your in-home detection. 

 

2. The default setting for 'Show Me' appears to be 'Playable on this device' and this selection isn't saved when you exit and re-enter the app. I will let the development team know about this bug (I'm sure they already do), and it will need to be resolved in a future app update.

 

For now, it seems like you've got the workarounds sorted. Sorry for the inconvenience.

 

Piky
Neighbour

I can access ChekTV from the list of channels on the Home tab so that function recognizes that I am connected to my home network but the 'payable on this device' function in 'Show me' does not recognize that I am connected to my home network. Rebooting and reconnecting to my wifi does not make any difference.

Kab
Connector

I am having the same problem on both the Telus box and the apps on a Apple TV and Android box.

Koach
Just Moved In

I am encountering the same issue. The channel guide consistently defaults to channels 'Playable on this device' no longer showing channels 119,121,125,2001.  I have noticed a similar issue with the Pik TV app on my computer.

 

On the home screen, the above listed channels are not displayed.  They do appear under the 'View Guide' menu but I get the following message when I click on the respective channel "Playback is only available when connected to your Telus internet at home"

 

 

KHR
TELUS Employee
TELUS Employee

Hi @Koach 

 

Are you connected to the internet on a VPN or with a firewall? If so, this makes it look like a different internet connection to the Pik app/browser. I just tested on Chrome on both a Macbook and a PC, and channels with out-of-home restrictions (119, 121, 125 etc.) work fine off my VPN, but when I turn the VPN on, they give the playback error you mention.  

KHR
TELUS Employee
TELUS Employee

Hi @Kab 

 

This is a known issue on the Pik media box, and the team is working to fix it. For now, the workaround is to access these channels from the home screen or to change the filter on the guide to 'My subscribed channels' from the default 'Playable on this device'. 

 

On the Apple TV though, I see that while the guide is defaulting to 'Playable on this device', the channel list and playability is exactly the same as in 'My subscribed channels' since the Pik app is recognizing the home internet connection. When you go to Settings (gear icon) in the top menu bar and then choose Account info and scoll down to In Home Status, what do you see? If it's not showing 'Connected at home', then your Pik app isn't recognizing your TELUS home internet connection. You may need to disconnect your Wifi/ethernet and reboot your Apple TV, and then reconnect your Wifi/ethernet to get it to recognize that you're at home.