Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sorry playback is only available when connected to your Telus Internet at home.

TELUS Employee
TELUS Employee

When trying to watch channels like amc and citytv i get an error message, it says " Sorry playback is only available when connected to your Telus internet at home".


I am definately connected to my home Telus internet thru my own router on the WiFi, this happens on my ipad app and android app, my STB is still in the mail, any suggestions?





Community Power User
Community Power User

Is your Telus Gateway bridged?


I have my PiK TV unit on my network router (unbridged and connected to the Telus Gateway) and am able to see channel 106 and the others which are only viewable when connected at home.  


EDIT: My Pik TV unit had defaulted back to connecting to my Telus Gateway when I wrote the above. I could watch using the PikTV app on mobile devices connected to my alternate router, but only as long as the PikTV device is connected to the Telus Gateway.  I'll have to dig further, and possibly do a few resets to further confirm.



What happens if you remove the bridge?  


The media box does not 'send a signal' per se, as it does not need to be on while you watch on your mobile device. I believe it is somehow tied to the IP address of your Telus Gateway, rather than your own router.


If you find a post useful, please give the author a "Kudo"

View solution in original post


Im having this issue today ....thinking ill get an ethernet cable

Friendly Neighbour

I been having the same issue for over a month, Telus has sent a replacement box and it doesn't help. I think the problem is internal mostly with their provisioning. I have no access to 6 different channels and rebooting does nothing to cure the issue.  I been on ethernet connecting since day 1.

I am also getting the OOH error and cannot get any resolution from the support team.

I have my PikTV box hardwired to my t3200 modem. I have done factory resets on every device, and tried everything and nothing will allow me to watch HBO or TMN, though I am subscribed to it, and am on my home network.

I have reached out to Melissa Jang and Sumeet Donnelly with no luck. Somebody please help!

Community Power User
Community Power User

Melissa and Sumeet are the PikTV gurus, and most able to help, as it may be a PikTV device issue, or more likely a backend issue. It was a backend issue for my device.


If you find a post useful, please give the author a "Kudo"

I am still awaiting a reply from Melissa or Sumeet from November 14, 2017...

I did live chat yesterday hoping to start 2018 with Pik working... but nope.
Apparently my movie channels, and craveTV were both cancelled in April 2017 without my authorization.
The rep told me this was done in order to keep me at the $20/month price point for Pik.

I advised that as a trial member, its supposed to be all inclusive for $20/month.
I then found a thread in our forums from October saying we can get it discounted to $10/month if we have TELUS DSL.
So I asked them to do this, as well as re-add the removed content, and they could not without charging me $100/month.

I now await a call back from L&R to resolve the issue and re-add my content.
It sucked being off for the holidays and then off to have my wisdom tooth removed and the majority of the content I pay for, was not available to me.
Then having to wait over 90 days just for a sign of life or resolution is just adding insult to injury.

My L2R on this product has gone in to the negatives lately...

I was not given a media box. It worked first time on my phone. Now I get the error in title. Doesnt Mayer what I resent or reinstall.

Community Power User
Community Power User

Are you connected to your home wifi or 3G/LTE?                            

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I am also having this issue. After reading through the thread, I thought running the PikTV box from the Telus modem/router on its own and putting the rest of my homes connections on another router would fix the issue. The 'Problem Solved' tag on this question is misleading, as it has clearly not been resolved. I feel I'm being billed for services I'm not receiving and should either have the problem resolved, or should be compensated for the products paid for, but not received. Telus, please address this issue.