Showing results for 
Show  only  | Search instead for 
Did you mean: 

Playback error on Microsoft Edge browser

Friendly Neighbour
Was working yesterday, today I’m advised of a needing to use new site address and now it doesn’t work. Message in the developer tools “uncaught (in promise) DOMException: The play( ) request was interrupted by a call to pause ( ).”

TELUS Employee
TELUS Employee

Is there something specific that doesn't work? Is it live TV, On Demand, login? Do you get any error codes?

Are you using an up-to-date version of Windows and Edge? Are 3rd party cookies enabled?


I just tested on v102.0.1245.41 on Windows 10 and it was working fine.

Friendly Neighbour
I’m using the Pik TV on Microsoft Edge, which coincidentally was updated yesterday on my laptop. I can see the everything normally on the app, but when I access the guide, then select a shoe, that’s when I get the playback error message. We’ve tried to troubleshoot as much as my software developer husband can and he stated it looks like it hits “pause” when clicking on the mouse when going to select the program.

Is there an error code that comes up? What is the exact error message? Have you tried multiple live channels (and ensured they're included in your subscription - try CBC or CTV)? 


Does On Demand work?


Finally, do you use any other ways to watch Pik TV? Apple TV, Android TV, mobile app? Have these been working fine over the past few weeks?


Details like this + the questions above will be helpful to isolate whether it's an operating system/browser version issue, a defect or an account-level issue (maybe something with your subscription isn't correct).

Friendly Neighbour
I have confirmed that all your suggestions noted above all produce the same result (playback error)

I can watch on my Apple devices but as they are an independent app, they would of course work.

I am having the same problem since a week ago. It stopped playing on Microsoft Edge browser all of a sudden and "playback error" message appears. I can play on Google though.

Telus support tried to resolve without success.


Friendly Neighbour
Yes, they gave me some lame workaround that never worked. I have experience in IT and it just seemed they were trying to disregard the problem. I just watch on my iPad Pro as it’s the only way at the moment.

I am having the same problem since a week ago. Pik TV stopped playing on microsoft Edge brower all of sudden and since then I keep  getting message "Playback Error, please try again later". I can play on Google chrome though.

Just Moved In

Same issue on the "new" Telus TV plus. Ridiculous it still hasn't been fixed after all this time, and they also took out support for Firefox 😞