PikTV status page?

Reply
Highlighted
Connector

For the entire evening I'm trying to start PikTV app and it just displays a blank screen for a while, then kicks back to Home. Netflix, YouTube, etc. work.

Is there a status page for the service, or is it always on our side?


Accepted Solutions
Highlighted
Most Helpful
Community Power User
Community Power User

Might be time for a reset of the PikTV device, then.

You will need to re-enter your credentials and may need to download fresh software.

 

NFtoBC
If you find a post useful, please give the author a "Like"

View solution in original post


All Replies
Highlighted
Community Power User
Community Power User

Sounds like the app is crashing. Did you reboot the Pik TV box?


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Highlighted
Connector
Completely powered off/on rebooted and PikTv app just won’t start.
Highlighted
Most Helpful
Community Power User
Community Power User

Might be time for a reset of the PikTV device, then.

You will need to re-enter your credentials and may need to download fresh software.

 

NFtoBC
If you find a post useful, please give the author a "Like"

View solution in original post

Highlighted
Connector
This happened to me too today. I called support and we finally had to do a factory reset from the Settings menu. Now working again.
Highlighted
Connector
Factory reset solved it for me as well. Frankly, I can’t complain about $10/mon, but PikTV is still beta and TELUS should allow for some form of diagnostics so that i don’t get yelled over by my wife when things stop working.
Highlighted
Helpful Neighbour

Similar issues. Media Box factory reset DID NOT help.

 

A long wait for support where they did something magical they will not explain (and they have no technical chops on the Pik platform anyway) and it works.

 

Until today when Application Load Timeout is my nemesis.

 

Pik has been in my first month of use far less reliable than it should be for a TV service. Streaming isn't new tech. What gives?

Highlighted
Helpful Neighbour

Note, the OP had asked about a service status page. No answer?

Highlighted
Community Power User
Community Power User
A service status page isn’t needed as the service is always technically “up”. It’s generally account specific or app related if it’s not working.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Helpful Neighbour

A status page navigable to from within the Media Box could display both back end status and local environmental issues, network connectivity, etc. Right now opaque error messages that magically go away after some period of time despite no local connectivity issues... point to issues at other parts of the application stack.

 

 

A service that is up but suffers from mysterious "back end" issues requiring a phone call or interminably long wait on chat support to reset some magic bits is not "up".

 

Nothing has changed on my account since set up just over a month ago. No channel changes. No credit card expiry date. Nothing - it's all as on day one. So why does some mysterious back end bit need to be flipped by support to clear an error that prevented the Pik app from ever starting on the media box?

 

The app's connectivity and authentication seem very fragile; Pik often will not work while every other online service available through the box work without issue. Why?

 

 

Highlighted
Resident

Have you tried clearing the cache on the Pik app?

I have had the same issues and this has seemed to solve it.  

Highlighted
Advisor

@yvrmike I had the same issue and it is most frustrating. Using the Reset button on the back of the device did NOT work. I had to do a Factory Reset and input all of my credentials (again). My Guide is very slow to come up when I press the Guide button as well as any other buttons on the remote. There is often a 10 second delay between pushing a button on the remote and the corresponding display arriving on my TV. Once again, very frustrating.

Highlighted
Helpful Neighbour
@AfterMath problem repeating now while I'm out of town working on Wildfires, leaving family a bit stranded.

Pretty crazy Telus.
Highlighted
Community Power User
Community Power User
Has the latest update been installed that was released a few days ago?

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Advisor

Yes, update has been installed (twice actually). Was there supposed to be an improvement b/c the Guide is still slow to react to user inputs. On occasion, the unit still refuses to go to Pik TV and jumps back to the Apps screen. Is it possible for TELUS to post the improvements that are to be expected with every 'update'? Similar to what one sees when updating an app on a Mac or PC.