cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pik tv

FZ
Just Moved In
Warning message “Application load time out pik services not responding” what do I need to do?
1 ACCEPTED SOLUTION

NFtoBC
Community Power User
Community Power User

Have you tried a complete reset and restore of the device?

NFtoBC
If you find a post useful, please give the author a "Like"

View solution in original post

8 REPLIES 8

NFtoBC
Community Power User
Community Power User

At what point are you seeing this message?

 

NFtoBC
If you find a post useful, please give the author a "Like"

I am having this same problem, i was on the telus chat yesterday and they said that they had sent a note to someone to do some back end work and would contact me with a resolution in 24 hours, i have had no contact with them. 

Pik TV is not very reliable, if i have to use internet for TV then I would be looking for a credit on the box as it has never worked to my satisfaction. 

NFtoBC
Community Power User
Community Power User

Have you tried a complete reset and restore of the device?

NFtoBC
If you find a post useful, please give the author a "Like"

View solution in original post

Even better. I replaced the unit because tech support had no answers. - rolls eyes-

So apparently they'll just offer you a new box... They sent me an extra one when I ordered the original services, so I had one sitting around.
I imagine it'll happen again, but for now it works.
I see this service going wayside.

I've tried the reset, the reboot, the disconnect and reconnect.   Nothing, I know it's not the internet connection b/c I can still use the Netflix and google apps.

 

It didn't post the first time I posted this. Sorry guys.

So tech said the boxes are" broken". Luck would have it I had one sitting around anyways. Telus sent me one even though I bought one in store.... So on short the new box works. I think it's just faulty tech and they're blaming whatever they can and just replacing them. I imagine a new box system is coming... And how they plan on making people pay for those after this charade.....

I did the full factory reset and it that has worked.   It's working again for now.  Until the next saga.  Thanks for the info everyone.

Aris
Neighbour

I am having the same issue. This is happening any time I try to even use Pik TV. I have rebooted the box, the internet, and support on twitter told me to chat in... thanks, tips. 

In essence....it doesn't go past this point. Ever.