Pik tv not working

Reply
kanitaria
Resident
So your pik tv service just died, wtf is going on
Community Power User
Community Power User
Unplug your box and plug it back in. I checked mine and is working as we speak.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

My Pik was offline as well. Standard troubleshooting didn't fix. It just came back online on its own a few minutes ago.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
clint17
Coach

Neither working here in the Okanagan (Error x-x-104)! Really looking forward to the new version next week, betting 10 bucks that the annoying errors will still not be fixed! Why? Because the geniuses at Telus prefer to introduce new features instead of fixing the s#1tty software for the box first. The errors are here for two years now, and nothing is fixed, really shame on you! Simply blame Harper, eh the box. Buy an AppleTV? I don't think so, that one also is still not working!