Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pik TV is now on Apple TV

Community Manager
Community Manager

Hey Neighbours, some exciting news! We're dedicated to providing you with new and exciting features that make streaming live TV better and easier. Our latest milestone puts Pik TV for the first time on Apple TV, providing an overall enhanced viewing experience without the need for additional hardware.


Here's some info on how to watch Pik TV on your Apple TV.


1) Start watching live TV on your Apple TV

Using your Apple TV 4K or any 4th generation Apple TV device, simply download the Pik TV app and login using your My TELUS credentials.


2) On Demand purchases

Currently, On Demand purchases are unavailable via the Pik app on Apple TV. We're working hard to enable this feature. In the meantime, you can easily make On Demand purchases through your browser or any Android device. In addition, you are still able to watch already purchased assets on your Apple devices.


3) Having issues with your Apple TV?

TELUS does not support hardware issues for Apple TV. For Apple TV related issues, please contact Apple directly or visit


For more details on Pik TV, please visit the Pik TV website

For support articles, please visit the dedicated Pik TV support articles

For more discussions topics, please visit the Pik TV Neighbourhood forums


Add-on to my last
Voice on the Apple tv goes to the Apple store.

Should also be able to search on TV programmations.

@Patthe thanks for the feedback - we're working hard to implement some changes to the app including some of the ones suggested. At the moment, if you use Voice in the Search section of the Pik TV menu on tvOS then it will return Pik TV results. Using Voice anywhere else in the app does currently bring up Apple's results, but we're working to address this. 

I am having a problem where I get a black screen with my Apple TV PIK set up after about an hour and  a bit  Perhaps I need to adjust the sound periodically.  I adjusted the go to sleep and did a hard reboot  as well as reinstalling PIK . I hope there  is a solution. I much prefer using the ATV over the Android box.  This problem seems to be only when I use PIK on Apple TV.

Community Power User
Community Power User


Does this happen as a show changes at the hour or half hour? If so, it is a known issue.


If you find a post useful, please give the author a "Kudo"

No I do not think the black screen happens on program changes - more like time about an hour 20 minutes.  I watched a movie with no interruptions though. This problem is fairly new to me.  If this is a known problem is there a known solution.  Today I reset to factory the ATV and reinstalled PIK just to see.  I would hate to go back to the Android box as it had other annoying issues. 

I factory reset my ATV and it did help  but today the black screen came on again.  Usually happens on HGTV in the middle of a program . Very annoying for my wife.  Has anyone connected a ATV 4K to their modem via coaxial to ethernet adaptors at both ends ?

Community Power User
Community Power User

@Nivende2 wrote:

 Has anyone connected a ATV 4K to their modem via coaxial to ethernet adaptors at both ends ?

Mine is connected by Ethernet. If you can't get an Ethernet cable to the location of your ATV, you could try MOCA and coax, or Boost Wi-Fi to improve your Wi-Fi signal.


If you find a post useful, please give the author a "Kudo"

How do you connect  the MOCA's .  At the T3200  router can I connect to the cable outlet using the cable output on the router or do I connect to the cable outlet using a lan port and a MOCA,  At the  ATV end i  have a cable connection so I would need another MOCA.  Basically how can  run ethernet to my ATV using my Shaw coax in between the router and the ATV using MOCA's ?

I figured out that I just need one Telus MOCA ECB6200 to get ethernet to my ATV  via coaxial from T3200M. The trouble is having ethernet to my ATV going to  solve the black screen issue ? Does Telus sell the ECB6200 ? 

Community Power User
Community Power User

They are available at BestBuy. You may be shocked at the price, though.

If you find a post useful, please give the author a "Kudo"

They are a little cheaper on and also appears to be actiontec selling them.

We have reached the end of the road on our PIK ATV app experiment. Telus hooked up the modem directly by ethernet.  The PIK went to black screen just like when the ATV was on WIFI.  I hope that Telus can resolve this problem for other users sometime in the future. Do not buy a ATV with the hope of a working Apple ATV app. Telus did try to fix the problem but  something must be wrong with the app. My ATV works fine except for the PIK app.



@Nivende2 - I'm going to send you a private message for some details, thank you for sharing on this forum and I do hope that I can resolve the problems that you're experiencing. 

Hi, I too created an account here to check on the status of the Black Screen issue.  Has the issue been resolved yet?  I am experiencing the black screen problem (not necessary at program change) on the ATV PikTV App.


I have a second issue that is similar to @YVRcub, when I try to play this particular channel (LSTV) on iPhone/iPad (through PikTV App and web browser), it says "Sorry, playback is only available when connected to your TELUS Internat at home" and I am on my home Internet.  I am able to play it on my Laptop web browser and PiKTV on ATV though.

Not been resolved but it does help to close all open apps before starting up the PIK app on your ATV.

How to force-close an app with the Siri Remote on Apple TV
Turn on Apple TV. While on the Home screen, double-click the TV button on the Siri Remote. ... Swipe to the right on the trackpad to find the app you wish to force- close. Swipe up on the trackpad to force the app to close.

Does force closing the Pik TV app temporarily stop the black screen / freezing for anyone?  Doesn’t seem to help my situation.


Last night I was getting non stop freezing / black screen on Food Network approx every 1-3 mins.  I tried force closing the Pik TV app and all other Apple TV apps, rebooting the Apple TV and even signing out and back into the Pik TV app, nothing worked.  Other channels I tried at the time seemed fine.  Today I saw the same behaviour on another channel (Knowledge Network).  It would freeze and go to a black screen every couple of minutes.  Tried another channel, and it has been streaming fine.


One interesting thing was that at the time I was seeing issues with Food Network last night, I also tried on my iPhone and was getting freezing also on both Wifi and LTE.  At this point I am unsure if it is the app itself, or just issues with individual channels at different times?  Really at a loss.


I would call Telus if you are getting problems across platforms. I never had that problem.

I spoke with support last night. After a bit of troubleshooting with the Apple TV app they said they put a request in to do a reset on my profile which could take 1-2 days. So I guess I just have to wait and see if anything changes. I have no problem watching certain channels for hours, CBC and CTV 2 seem fine, others like Food Network can barely go 5 minutes without getting a black screen.

Really disappointed with PikTV so far. Will have to cancel if this isn’t fixed.

@themikea Hi! I'm on the Product team for Pik TV on Apple TV and wanted to let you know that we identified root cause and we are working on the fix. Once we test it out and confirm it resolves the problem we'll be providing an app update to resolve the issue - stay tuned!

Great, love the ATV app. Test the new app on hockey games too. Lately I have been getting instant black screen on the Oilers game (masochist) . Usually the game is offered on more than one channel and by trying all availability for Oiler game channels I was able to get the game going. HGTV goes black after an hour or so. I aways close then open the app when I watch PIK.

Sent from my iPhone



Could that be an issue with the Android box too? Would be nice if somebody looked finally at that p.. too! For the last four months nobody seemed to really care.


Any help to get a halfway working product would be nice.