Showing results for 
Show  only  | Search instead for 
Did you mean: 

PIKTV not working at browser using chrome + linux




I am having an issue with It works well on chrome and windows. However, when I try to watch it on chrome and Linux, it keeps loading forever. has someone faced the same issue? 


I've authorized and flash is installed. I can check when I hit this URL chrome://flash/



Google Chrome67.0.3396.87 ()
Flash plugin30.0.0.113 /home/gabriel/.config/google-chrome/PepperFlash/
 --- Crash data ---
crash id102885e3d0ac9af7 Thursday, 21 June 2018 at 10:17:57
crash id6065fd6dda4598e6 Tuesday, 16 January 2018 at 15:29:21
crash id13231b16a8450936 Wednesday, 13 December 2017 at 16:34:47
crash id76e2692192e83872 Wednesday, 13 December 2017 at 15:33:12
crash idac14c9e704b82f74 Tuesday, 12 December 2017 at 11:36:58
crash idae923428827b001a Wednesday, 6 December 2017 at 09:08:33
crash id6d5ef2fff1fee039 Monday, 20 November 2017 at 11:41:32
 --- GPU information ---
 --- GPU driver, more information ---
Vendor Id0x8086
Device Id0x0412
Driver vendorMesa
Driver version17.2.8
Driver date 
Pixel shader version1.30
Vertex shader version1.30
GL_VENDORIntel Open Source Technology Center
GL_RENDERERMesa DRI Intel(R) Haswell Desktop
GL_VERSION3.0 Mesa 17.2.8
GL_EXTENSIONSGL_3DFX_texture_compression_FXT1 GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_trinary_minmax GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_window_pos GL_ATI_blend_equation_separate GL_ATI_draw_buffers GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shader_integer_mix GL_EXT_shader_samples_identical GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_INTEL_performance_query GL_KHR_blend_equation_advanced GL_KHR_context_flush_control GL_KHR_debug GL_KHR_no_error GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_MESA_pack_invert GL_MESA_shader_integer_functions GL_MESA_texture_signed_rgba GL_MESA_window_pos GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_OES_EGL_image GL_OES_read_format GL_S3_s3tc GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays

Community Power User
Community Power User

Which linux are you running? Can you turn of all blocking of domains and ad blockers and see if it'll load?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

View solution in original post


Community Power User
Community Power User

Which linux are you running? Can you turn of all blocking of domains and ad blockers and see if it'll load?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks for your reply. I am using ubuntu 16.04 LTS. I've already disabled ad blocks and also started incognito window. But all of these attempts were not successful :(.

Community Power User
Community Power User

All I've got is LinuxMint 17.3. Did some testing just to see.


I have a slightly newer version of Chrome than yours. (67.0.3396.99). Flash is the same at

  • Login OK
  • Tried watching a few different shows as well as On Demand. Spinning wheel, no content.
  • Re-installed flash. No change.

Decided to try Firefox 60 for Linux just for the heck of it. Same Flash version as Chrome.

  • Login OK
  • Tried watching a few different shows. Spinning wheel, no content.

Chrome on Windows 7. Works no problem. Same version of Flash.


I wonder if it's something with the Flash plugin for Linux, Linux (even though we have different versions) or something else that's not working. It's not just Chrome affected on Linux.


@psl - Any ideas?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

ya, it's the same behaviour here. Spinning wheel, no content. Here also you can make login and browser through the content, but when you click to watch. No luck.




I've got exactly the same problem.  Registered for PikTV to watch FIFA but kept getting spinning wheel in my Ubuntu 16.04 installation. 


I use Gentoo on a work laptop and here is what I did:


- downloaded latest '' from Adobe Flash (included in 'flash_player_ppapi_linux.x86_64.tar.gz' source) 

- ran 'mv'

- ran 'sudo cp /usr/lib64/nsbrowser/plugins/'

- and 'sudo cp /home/me/.mozilla/plugins/'


And it worked in Firefox 59.0.2!


The problem is that my Gentoo system is sort of messed up and I can't update it so this Firefox version is the latest one I've got (I know there's 61 now available).  Not sure, but maybe it works because I've got an older Firefox version?


Anyways, even though it worked, I don't think it's a solution because my Gentoo system is out of date and hasn't had a system update for over a year (my fault, I know).  I'm only using Ubuntu for watching movies online (like Netflix) and PikTV is not working for me in Ubuntu either.  There needs to be a more permanent solution that works with up to date Linux software, or Telus should mention explicitly that PikTV is for Windows and Mac only.


P.S. also installed latest Ubuntu 18.04 yesterday hoping it would work with PikTV, but the same problem - PikTV is not working.