Netflix & Gray Screen


Netflix & Gray Screen

I've been a PikTV user for quite some time. It's a great device when it works but I have been having lots of issues. Recently, while watching Netflix the screen turns gray and then the PikTV box shuts off and restarts. I find that I only have this problem when I watch Netflix. Even after rebooting the system, it still occurs.

I've tried everything...i.e. Restarting box, killing other apps. Has anyone else encountered this?
Helpful Neighbour

I've been having this problem since early nov'18.  However I get a static screen of gold/bluish/silver snow, not gray.  


It used to happen maybe once every 2-3 weeks, then increased in frequency in jan'19 to 1-2 times per week then daily. This month (feb'19) it's much less frequent. 


It's very erratic when it will happen. And it can go for days between occurrences. When it does happen it seems to be limited to the show/movie I was watching. Even after rebooting it'll crap out at the same spot or a moment or five later. However, if I watch another show/movie it'll be fine. 


It's almost like there's something in the Netflix stream that trips a bug in the Netflix app. 


Reboots, factory resets of the PIK TV box will not fix it. It seems to cure itself with time. Either watch some other Netflix content or watch TV. After a day or two it seems to be fine. I know not ideal.


I don't think this is under Telus's control. I think the Netflix app comes from the Google app store and I don't think Telus wrote it.


Community Power User

Netflix requests that users contact them when issues like this occur. That will be the best way for them to address it in future updates to their app.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

In contact with Netflix support right this minute.

So far they're saying to have Telus check their firmware is compliant with the Netflix app requirements.


Netflix Gerardo
Yes, it is but please note that the device that you are using must comply with the requirement of the app for it to work. That is why I suggested that you contact your device manufacturer so they can check if they have any available firmware upgrade in it to comply with the app.
Community Power User

@psitech I seriously doubt it's the firmware. It's standard Android TV OS. For me, in extremely rare instances Netflix may crash but the majority of the time it works fine. The last Netflix employee I chatted with was far more helpful and actually took a report of what was going on, version of the software, etc.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Helpful Neighbour

Has anyone tried to update the Netflix app from the Google Play store? 

Friendly Neighbour

Yes, have tried updating the app, I also tried uninstalling updates and even uninstalling and reinstalling the app - still have the same issue.



When the box restarts after getting the snow screen viewing Netflix, where does it come back to after restarting? Netflix, Home, TV?

Friendly Neighbour

@psitech it comes back to TV.

This isn't a solution but a tested and functioning workaround: unplug the PikTV box for a minute or two. When you plug it back in it will function normally without crashing. 


This clears any volatile memory in the capacitors, and is the only way to do that. It appears that this bug causes a corruption in volatile memory which accrues with use and therefore seems to crash the unit with increasing recurrence until it's cleared. This means it will be an ongoing workaround; after several days your unit will crash again and you will need to repeat the procedure. So it's a nuisance, but at least you can watch TV in peace.


It also means it's likely a firmware issue, so is Telus' responsibility to fix.

Helpful Neighbour

I've been doing this since jan'19. Pull the power plug and reconnect. It used to work, but now (spring/summer 2019) it doesn't work at all. Netflix will fitz out almost immediately.

This problem is so bad now it is rare that I can watch a title to completion. Even the previews of titles as I scroll through the list can fitz out. I've almost given up using the Pik box for watching Netflix. Can anyone recommend alternatives? 

I watch Netflix without issues title after title.. Try a factory reset and reload all the apps you had previously installed.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

This issue has been ongoing since Pik came out. Telus doesn't seem to care about fixing it. I'm near the point if canceling it

Has anyone  noticed that Netflix seems to be working now?  For the last couple of days I've been able to watch multiple titles in a row without Netflix fitzing out.  


I'm not aware of any software updates. Maybe it was a problem in the Netflix stream and that has been fixed by Netflix.  Either way for now it seems to be working. 

Never had an issue for at least 3 months with Netflix. No Pik TV updates have been released. 

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.

I have contacted Netflix regarding this issue as you suggest Nighthawk, unfortunately I have never heard anything useful that could fix the issue from anywhere (Netflix, Telus, message boards etc). It's just a little frustrating that it continues to happen

This is just getting ridiculous it is happening all the time now! You can’t even get through a half hour show!! On my main tv I got rid of the box and just use online. I have the box in the bedroom and it craps out after 4 min in Netflix and does a reboot to just do it again!!!
Friendly Neighbour

Yes, this has been an ongoing issue for quite some time for me, and it’s really frustrating as there doesn’t seem to be a fix anywhere


Yeap. Telus sippprt has been utterly useless