My Pik TV box not showing any wifi connection

Reply
Highlighted
Resident

As of late last night my Pik box is not showing any wifi activity the middle light is not lighting up.

1. I have tried rebooting(unplugged for 10 sec and then again for 2 min)

2. Tried the reset on back of Pik TV box (Doesn't seem to do anything)

3.  Connected Pik TV box to router with Ethernet cable and rebooted nothing still.

4. I went into router setting and Pik box shows as unknown device with ip address and shows packet activity(only when connected with Ethernet cable) but still nothing showing on TV.

 

Is this a known problem and if so whats the fix. Or has my PIk TV box come to end of life and i need a new one.

Any help on this issue would be great and thanks.


Accepted Solutions
Highlighted
Most Helpful
TELUS Employee
TELUS Employee

Hi @Mike61 

 

I'd recommend rebooting the Pik box after disconnecting from the internet. 

 

1. Disconnect any ethernet cables.

2. Go to the Android TV home screen --> Settings --> Network & Internet and turn off Wi-Fi

3. Go back to the Settings menu, then Device Preferences --> Reboot

4. After rebooting, try re-connecting the Wi-Fi.

 

If this fails, you may need to call in for troubleshooting.

 

View solution in original post


All Replies
Highlighted
Most Helpful
TELUS Employee
TELUS Employee

Hi @Mike61 

 

I'd recommend rebooting the Pik box after disconnecting from the internet. 

 

1. Disconnect any ethernet cables.

2. Go to the Android TV home screen --> Settings --> Network & Internet and turn off Wi-Fi

3. Go back to the Settings menu, then Device Preferences --> Reboot

4. After rebooting, try re-connecting the Wi-Fi.

 

If this fails, you may need to call in for troubleshooting.

 

View solution in original post

Highlighted
Resident

Thank you for your reply. I did try you suggestion with no luck. So i went for a factory reset and used Google home app on my smart phone to re setup my Pik TV account on my TV and this has worked for me in getting my wifi up and working on the Pik box. Once again thanks for your help.