Showing results for 
Show  only  | Search instead for 
Did you mean: 

Broken Apple version of Pik tv app

Since the update I have not had a better experience. In fact the pik tv app is unwatchable. It pauses, freezes. Then fast forwards itself. The best part is this is only happening on apple tv box I got from Telus. And the pik tv app. All other apps (Amazon Video, Disney+, Apple TV, and Netflix) all work fine. Spent the last 2 mornings uninstalling and the reinstalling the app. Super frustrating. And no support. Short of "uninstalling and reinstalling fixes it all the time."
That's not support... And it doesn't work....
Some help in finding a resolution would be great!

Our app development team is aware of the issue and working to resolve it. It's not widespread, but I know that's of no consolation if it's not working for you. My apologies and thanks for your patience. 

View solution in original post


Update. Chatted with an agent who advised it’s an issue with Single Sign On in the app. There’s an AppleTV app update coming. But in the meantime he advised:- sign out from PikTV in settings, then launch the app and sign in there. If it asks for permissions, ignore. Well I’m trying that. And it still doesn’t help.

Deleted the app. Rebooted. Installed the app. Signed in and ignored the warning as requested. Fail. The video is still pausing. So we will have to wait for the update coming next month.

Disabling the Apple provider login worked for me. Using the login with the PIK app.

Today is the first time we've had any major issue with the Pik TV app for Apple TV (have been using it for over one year). When a channel is selected, there is audio but no video at all - black screen. No changes have been made to the Apple TV recently and other apps still working fine.


I tried getting out of the Apple Single Sign-in as advised, and also have deleted and reinstalled the app, restarted Apple TV, unplugged - all the usual and recommended things. Telus needs to fix their Pik TV app for Apple TV

Update: Disabling the Apple single sign-in and logging in with the Pik TV app did not resolve the issue yesterday. However, several hours later, tried Pik TV app again and the video issue had spontaneously resolved. Still streaming today...

Waited on hold for 2.5hours on the Telus callback today. Went through the same explanation that the video pauses while the audio continues, followed by the video catching up with the video. There doesn’t appear to any record of this issue OR it’s complete incompetence. Escalated and hoping that this will cause something to happen. Totally unhappy with the poor service. That’s 4 calls now without any sense that anything is being done.

Helpful Neighbour

same response and commitment to get back to reading all of these comments one can easily see that Telus is well aware of this issue, has been for many months, but when I called five days ago they were dumbfounded, never heard of the issue  and upsold me on a faster ethernet delivery.


for all the posters that have this issue which appears to be unresolved....where do you or did you go for a replacement?  We like the limited number of stations that one can subscribe to so a full cable spectrum is not of interest...are there other Apps for an apple TV of do you need to replace the Apple TV with a Roku for similar?

Our PIk has worked flawless until this issue and a few others arose (multiple stream and others)

Clearly the App is buggy and it appears that Telus is not willing to or cannot correct the problem

called Apple support and they are opening a ticket.....suggest everyone call as I was the first to bring this to their attention

spoke to a senior wireless technical guy at Apple Canada....we tried the Sign out procedure mentioned in this thread but ...BS.  He said they will flag the problem but as all other apps are working they're opinion is that is a Telus issue but, as posted here by others, Telus is dodging the issue.  Like others here, I was told by Telus Tech they would elevate the issue and get back to me in 24/48 hours...not holding my breath.

Time to look elsewhere for phone/internet/TV

So. Took another call from a Telus tech the other day. He confirmed it was indeed a problem with their app on AppleTV. Well at least that’s something. No more messing around trying to convince them there is a problem. He said they had my video plus another that illustrated the problem.
BUT. It’s a third party developer. And there is no word on if or whether it will be fixed by the developer. SoL.

Helpful Neighbour

Glad to hear they acknowledge the issue… the interim we’ve installed PIK on our large Sony Smart tv (Android/google) and is working well although for our small kitchen tv no such luck as the second Apple TV is the only access point for that little dumb tv.

we will be seeking some prorated reduction in costs for lack of service, now six days in.   And to think I was talked into upgrading the internet package as the proposed solution…silly me.

here’s hoping they can solve this….for us PIK worked just two weeks ago

Helpful Neighbour

Can confirm. Same issues occurring for me and seems to have started about 2 weeks ago.


Hoping a fix comes soon.

Anyone know if this issue has been fixed? I've been experiencing it for a few months and have tried all the troubleshooting steps.

I have Telus gigabit fibre internet, an Apple TV running the Pik tv app version1.6.1 and I am trying to watch the Oiler game.  The live feed keeps freezing for 5 seconds (sound keeps going) then the picture speeds up to sync back with the sound.  Every other app works flawlessly.  This problem has not been fixed by Telus.  Time to switch to Shaw 


The only way I have found to sucessfully stream PikTV is either;-

1. use the Android TV application. I have a sony TV that is android 7 based and the app works flawlessly

2. stream via a web browser on a PC

The apple apps - both on the AppleTV and iPad are broken and Telus refuses to accept responsibility, blaming their implementation partner who developed the app, or blaming Apple... TELUS IF YOU'RE WATCHING THIS THREAD - SHAME ON YOU for not stepping up and addressing this issue with your service delivery!

Just Moved In
Oct 2021 and this app haven't been fixed.... Was running great since Jan 2021 but for. The past month it's just gotten worse