Authentication error when cell phone tries to connect to home wifi.

Just Moved In
For the last couples weeks my phone keeps disconnecting from my home wifi or failing to auto reconnect when I come home. When I check the wifi status it says authentication error. The password is correct, sometimes when I try to reconnect it will work on the 3rd or 4th try. I have turned off the smart switching so I now have two networks one 2.4g (which I renamed and removed the -2.4g from: "homenetwork-5g & homenetwork" I am still having connection issues even though I've deactivated smart switching and my wifi network is very strong... I have several other devices and smart home devices connected with strong signal that never fails. Any other ideas? I'd say it was my phone but I don't have the issue anywhere else and it just started at home a couple weeks

Which phone? Have you searched your phone model to see if others are having similar issues?


Have you tried forgetting the SSID on the phone and starting over?

Just Moved In

To authenticate, your phone has to be 'at home.'

Try to make sure your phone's on your home network exclusively when attempting again, but this can be trickier than it seems. 

Your home also has to be set, I know this is odd, but make sure your set top box is powered on, but if it's already on, power cycle it so that it has a fresh 'home.'

Additionally, many modern phones have a 'wifi assist' feature that turns data on when it finds the wifi to be inadequate. The measuring done on these features is very arbitrary, meaning it can actually be hard to tell sometimes.


Disable data, but also disable wifi assist on your phone, and then try again.

Here's how to do it on ios;


and here's how to do it on a lot of android devices;

Just Moved In

Wait my above post I wrote, I thought you were getting that error on PikTV on your phone.

If this is just about your wifi;

- Make sure MAC filtering isn't enabled on your router

- Power off your phone (not sleep but physically power it off)  and then power it back on.

- Make sure your router firmware is up to date and also if that still doesn't fix it...

- Factory reset your router. 

Just Moved In

I even tried using a static IP address but the authentication error would still occur.