cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Android app issues

Abangert
Helpful Neighbour
I've downloaded the Android Pik TV app to my Samsung tablet and getting an error message to the effect that the app has "stopped". I have deleted and re-installed the app to no avail. The IOS app works fine on my iPhone. Any thoughts in what's going in? Thanks very much!
24 REPLIES 24

xl
CPU Alum
CPU Alum

to clarify.... which Samsung tablet?

Abangert
Helpful Neighbour
Thanks for responding so quickly! It's an older one - Galaxy 3. Haven't had this issue with other apps though.

I'm wondering the age of the tablet (slower processor) could be an issue.  Let's see what others think.

Nighthawk
Community Power User
Community Power User

Which version of Android is on the device? Pik requires 5.0 or higher.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Not sure, but that could be the issue. I'll check. Thanks again,

WestCoasterBC
Community Power User
Community Power User
I believe that tablet is stuck on 4.4.2 kitkat. Custom roms would be the only way to get 5.0 but that's at your own risk.

Confirm your model number.

Will do - maybe time for a new tablet! Thanks again to the forum for your help.

Abangert
Helpful Neighbour
Checked into tuis - it's a Galaxy 3, model # GT-P5210, running Android 4.4.2

NFtoBC
Community Power User
Community Power User

Looks like your next step is clear!  😎

NFtoBC
If you find a post useful, please give the author a "Like"

Abangert
Helpful Neighbour
Yep - off to Best Buy I go!

WestCoasterBC
Community Power User
Community Power User
You could probably sell it for a few bucks and recoup a tiny portion. Don't give into the BestBuy upsells 😛

Good advice. Thanks, WestCoasterBC.

Abangert
Helpful Neighbour
I am having enormous problems just connecting my Pik TV box to wifi. I sent back the first box after spending 1.5 hours with a TELUS agent troubleshooting possible router issues. He finally gave up and said the box was faulty. 8 days later I'm having the same issues with the second box that arrived today. It simply will not connect to my wifi account. I have a brand new TELUS router and none of my other devices have any problems connecting. Am I alone here? Thanks for any insights!

Nighthawk
Community Power User
Community Power User

Mine connected to either of my routers on the first try. Does your give you an error or some unusual message? I do have my Telus 3200M gateway set to 2.4GHz wireless though.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks - I have the same router and the only message I get is "couldn't connect to _____".
I'll try 2.4GHz and to see if that makes a difference.

NFtoBC
Community Power User
Community Power User

Same as @Nighthawk, no problems connecting to any of 3 different Wi-Fi signals. Can you run a temporary Ethernet cable to the device and see what happens?

 

Are you setting it up using the remote, or an Android phone? I had problems using the automated process with the phone, and reset the device, and had success using the remote only.

 

 

NFtoBC
If you find a post useful, please give the author a "Like"

Abangert
Helpful Neighbour
Thanks for getting back to me. I'll try running a cable as you suggest. I am trying to set up via the remote but being told the pairing is unsuccessful. The remote seems ti be working anyway. I also tried setting up via Android, with no success.

NFtoBC
Community Power User
Community Power User

It uses WPS to connect, correct? (It's been a while) Make sure you are holding the WPS button on the Telus gateway/ router long enough. I held it for about 10 seconds.

 

NFtoBC
If you find a post useful, please give the author a "Like"

Nighthawk
Community Power User
Community Power User

WPS? I just typed in my password for the network. I disable WPS on all my routers. 🙂


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

You can always use USB keyboard and mouse for setup if you have one kicking around. I've had no problems connecting to the Telus supplied 3200M or my own.

I can't see you receiving two dud boxes with the exact same issue.