cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Android Pik TV app doesn't work after update - Error 6006

Jfattog
Neighbour

App was working until it forced me to update a few weeks ago. Now I get error 6006 every time I try to play something. Tech support did not have any information on this error.

 

I have an older but top end Android tablet (Samsung SM-T700) with Android OS version 6.0.1, which is apparently compatible according to the Google Play notes:
• Pik TV app is available for download on mobile devices running Android 6.0 and above
• Subscriptions to TELUS Internet and Pik TV are required
• My TELUS username and password required to log in

 

Can I "downgrade" to the previous version of the app which was working perfectly? Or is there a fix coming? I can't continue paying for a service which I can no longer use.

0 REPLIES 0