Unable to setup Chromecasts

Reply
Neighbour

Hey Everyone,

I've had 2 Chromecasts connected to my Telus router and they were working fine up until a week ago. One would constantly have problems connecting so I did a factory reset and tried to setup again. It could do everything but wouldn't connect to the router. I then restarted the router (I have the new white one that looks like a cylinder) and tried again with no luck. What's worse is that the other Chromecast that was working fine won't work now either and I can't set it up as it can't connect to the router! Any help please?

Guardian

Are your other devices able to connect to the router?

Are your Chromecast devices 1st generation (2.4 GHz) or newer (5 GHz)?

Do you have 1 SSID or 2 different SSIDs for your WiFi?

Can you confirm the "white cylinder" is an Arcadyan router?

Neighbour

Also do you have extenders.  My chromecasts don't work when the phone I use is on a seperate access point.

 

Talking with TELUS support it sounds like a limitation when using a network built off the Arcadyan router.

 

I'm likely going to return my boosters and get my own mesh router and bridge it to the Arcadyan router which does have a bridge mode luckily.