Showing results for 
Show  only  | Search instead for 
Did you mean: 

Troubles with Optik TV


Good day

swtiched from Shaw to Telus a few months back.  I was having a lot of problems with my internet, but the TV and home phone worked fine.  I managed to fix the internet by:

- Running a CAT6 cable from the fiber optic box in my garage to my living room.

- Setting up my modem in the living room

- Bridged the modem

- Ran CAT6 cable to a few locations in my house

- Installed ASUS zen wifi mesh system with routers located throughout the house.


This resolved all the internet issues I was having, and am now getting excellent speeds.


However, since doing this, I have had trouble with my optik tv.  My main optik tv box is located in the living room right next to the telus modem.  I have a network cable connecting to the optik box to the telus modem.  When I watch TV, after a few minutes, the picture and sound start to cut out.  It's an intermittent problem.  I can watch for 5 to 10 minutes without an issue and suddenly, the picture and sound freeze.  The problem appears to be worse on the 4k channels.  The video only appears to freeze when a goal is scored (I think this may just be a coincidence and not some grand conspiracy).  


Further, my other two boxes that I connect wirelessly to will barely work.  They will initialize and run for about 60 seconds.  After this, they give a loss of signal error message.  I even ran a network cable and set up the telus extender close to the boxes and got a similar result.


I called Telus last night and spent about 30 minutes on the phone.  The support was limited to rebooting the modem and tv box (which I've tried numerous times).


Video of what I'm experiencing on the main box 


I'm a little concerned.  This problem appears to have started when I bridged my modem.  Bridging the modem was the only way I could get good internet speed and coverage in my home.  I'm concerned that I can either have good internet via a bridged modem or good TV, but not both.  Any ideas on what I can try?  Primarily I'd like to figure out what's wrong with the main box in my living room.  I'm very surprised that I'm hardwired directly to the modem via a network cable and I keep losing the signal.



A quick update.  I did a bit more troubleshooting last night.  I managed to get the second box up and running.  Turns out there was a network cable attached to the back of the box that was connected to a router that is part of my mesh system.  I unplugged it and the box has been up and running ever since.  No issues with video or audio when watching 4k channels.


The main box is still an issue.  Here is what I've found:


- When the main cable box is plugged directly to the telus router via a network cable, all channels freeze periodically (4k channels freeze more frequently than the rest).

- When the main box is connected to the router via coax cable and coax to network cable adapter, all channel free periodically.  The channels freeze less frequently, but for longer durations. Again, 4k channels are worse than non 4k channels.

- I'm baffled as to why a cable box connected via wifi performs flawlessly while the box connected via a cable is problematic.  I unplugged the network cable from the main box, and it will not connect to the router via wifi.  I'm assuming it's set up as the PVR and requires hardwire connection to operate?


Tonight, I'm going to use my third cable box in the living room.  I'll leave the main box plugged in, and set up the third box over wifi and see if it'll run in the living room.  If this works, I'm going to call Telus and tell them I need a fourth box in order to operate three TV's (not sure if they'll issue one for free).


My biggest challenge is explaining the issue to the tech's over the phone.  Their solution is the same:  unplug the boxes and let sit for 10 minutes, plug back in and everything is fine.  It is fine, for about 30 minutes and then it goes back to the same problem.  The techs on the phone are not interested in discussing how the boxes are connected.  All they seem to want to do is reset everything and hang up.

Community Power User
Community Power User

It could be a problem with the main box as well. It may need to be replaced. If you've tried multiple ethernet cables, as well as coax, that would leave the box as a likely cause of the issue.


Is the main box connected directly to the TV or through another device like a receiver? Have you tried another HDMI cable?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Hi Nighthawk;


I have tried a couple of different network cables, but haven't tried switching the HDMI cable.  I will try that tonight.  The main box is direct to the TV (no receiver....... yet.  Have to figure out a way to sneak one into the house without the wife noticing).

Hi again Nighthawk
I used a different HDMI cable and there was no change. Moved the second box from my bedroom to the living room. It works flawlessly. I'm going to try and contact telus and ask for a new main box. Or ask them for another wifi box and I'll run it in my living room next to the main box.